IntelliJ IDE 2020.1.2 debugger not stopping at breakpoints



I recently updated my IntelliJ IDE and now the debugger has stopped working at the break points. Let me know what should be done.


What is the type of application? How breakpoints are configured? Is it possible to record a screencast of the reproducing, or share a project (included .idea folder) where this could be reproduced? You can share it privately:


Hello Konstantin Annikov,


I am facing the same issue, and the steps that I've followed are:



1 - I just created a new application

2 - added a breakpoint at the first line with a console.log


I am able to see the console log being printed, but isn't sopping before that! I even tried to create a new variable just to see if the issue was breaking on a console.log line, still could not get it.


Any solutions for this? 



What Node.js interpreter do you use? Also, do breakpoints on other lines work? Could you share a screen recording of the issue?


I will try to describe to you using screenshots 


1 - This is how i am creating a new app

Note: I am using something that was built to work


2 - this is the result after finish the npm instal


3 - Adding breakpoints on bin/www as well as on [root-folder=/app.js


4 - As you can see I am running the basic express app developers by you guys as a boilerplate


Wanting to show you that isn't a cached thing, I had to change 2 things:

1 - The text to become express 2

2 - a console.log with a text: HERE!!! so you could see that passed and nothing happened, should stop but I only got the console.log without showing anything on the debug tab

Sounds like is missing something to connect between the IDE and the browser


Note1: I remember that I had to do a few things in a workplace before (PHPSTORM) to connect with a docker environment, I had to set a cookie so the browser so Phpstorm could understand that was a request from the localhost machine to the chrome browser, is that the case?


I hope that all screenshots can be enough!












it works fine for me using the same Node.js version:

Do you debug locally, or in a Docker container? Can you see any errors in the debugger console? Also, could you reproduce the issue and share your idea.log (Help > Show Log in ...)?


I am sorry, f works fine for you, can you please send me what is the version that you are using like the Debian file, so I can install all over again and test it again?


Here I can't see any error, It just shows the console.log, as I am showing in the picture below


We only have the text being printed and that's it! 


I think that the only difference between you and me now could be what is installed in my webstorm? 

I am sending attached all my installed plugins




If you can find a plugin that I shouldn't be using, or should I remove, please let me know so I can do it so...


please could you share your idea.log (see my comment above)?


Nothing suspicious in the log, and your custom plugins don't break the debugging for me.

Please try disabling js.debugger.use.node.options key in Registry... (Help | Find action, type Registry to locate it) - does it make things any better?



Hello Elena Pogorelova,


With these changes the debugger started to work, is it ok to continue without that option? (I think that at least an article on your wiki should exist for another case like mine)




It's OK... With this option enabled, WebStorm uses the NODE_OPTIONS environment variable to pass the debug flags to node.js processes. For some reason this doesn't work in your environment - the variable is either not set or overwritten...


I have disabled this option and still cannot pause execution and the debugger does not stop at breakpoints by default.


@Josh C your issue is different then; please start a new thread, providing the detailed problem description


I had this problem and it was because I was passing NODE_OPTIONS in my npm script. I changed it to 

NODE_OPTIONS=\"$NODE_OPTIONS --max_old_space_size=16384\" nx test vcd_ui

And I can debug it now.


Please sign in to leave a comment.