CLion unnecessary forced line wrap in console output

I want to print a long line but Clion forcefully wraps my output. I even tried to go to setting to change line wrap of code but it works only for code. In console, I have tried to enable/disable Soft-wrap, but it seems no working.

I habitually try to print long lines in pycharm and intellij idea without any line-wrap. Clion behaves strange.

 

7 comments
Comment actions Permalink

Hi!

On what OS do you use CLion? What toolchain do you use?

0
Comment actions Permalink

I see the same thing:

In CLion, on Linux, in the Terminal view.

0
Comment actions Permalink

alieuall in case of Terminal please try disabling "Use soft wraps in console" in File | Settings | Editor | General | Console.

0
Comment actions Permalink

No change.

 

0
Comment actions Permalink

alieuall please create an issue in the IntelliJ platform's tracker: https://youtrack.jetbrains.com/issues/IDEA.

0
Comment actions Permalink

I have the same issue on IDEA 2021.1.3 on Windows and git bash as terminal

debugger links have unwanted line-breaks

0
Comment actions Permalink

Same issue CLion 2021.2.3.

0

Please sign in to leave a comment.