How disable auto closing of brackets, quotes, curly braces etc. for all file types?

Answered

Hello everybody,

I work at an webdev company and we recently switched from eclipse to IntelliJ. I really like IntelliJ over eclipse as many thing go faster. However I have a big problem with the Autocomplete-Features in IntelliJ. Most of it is really helpful, but some things are extremely annoing and even hard to find in the settings. One of these things is the automatic closing of brackets, curly braces, quotes and things like that. I hate these type of functionality and this is one of the first things I disable in every IDE so far. For example I often write code and add the braces or brackets later but once I create the open-bracket the IDE automatically creates the close-bracket behind and I have to delete it. This feature has helped me never so far (no joke). I have found some flags within the setting that seem to disable this feature in java-files but I can't find any setting that would disable this feature in HTML-files. The chars <, ", { ... will all be automatically closed. Is there a setting that disables this feature for all filetypes and languages?

6
20 comments

Hi Berger,

You can check the File | Settings | Editor | General | Smart Keys page for Java-related options, and also its child pages for other languages:

2

Thanks for the reply, but that doesn't stop intelliJ from auto-closing quotes for example. I have disabled 'Insert pair quote' but it still auto-closes quotes in css files and within the css-section of the SmartKeys-Options, there is no switch for 'Inert pair quote'. Please make "never autoclose anything in any file" to an option in the settings. That autoclose feature is incredible annoying. Im constantly deleting more quotes that I had written in the first place. The same goes for bracktes & curly braces. I could disable the autoclose in some of the files but now an then it still autocloses something there.

PLEASE give me an option to disable Autoclosing once and for all in every file (html, java, css, ...)

2

What kind of syntax are you referring to when saying that "it still auto-closes quotes in css files"? 

With the following options disabled, I am not getting any auto-closing of quotes and brackets in css and other files:

Can you provide a few examples? Also, what version of the IDE are you using?

2

Never mind. Tried to reproduce. Seems I selected the text-part beforehand and wanted to replace it with a quote.

Before:

'test' = ....

I selected the first ' and typed ". Expected to replace the ' with a " but it quoted it instead.

After:

"'"test' = ...

I think this feature may come useful in the future so just ignore my comment. Thanks for your effort.

0

No worries at all. The option you are describing can also be disabled if necessary:

2

This preference flag doesn't seem to work for me. 

Autocompletion of quotes and braces is infuriating - it is not the kind of help I need - that kind of shallow second-guessing for a trivial keystroke (literally the least-effort action of all possible actions I would take in an editor) virtually ALWAYS leads to frustration and distraction.  At the minimum, it means I have to go backspace and fix the syntax error, and then hit the misfeature again, over and over. 

I'm editing a PUML file. I have the options you highlighted turned off.  Yet, it auto-completes quotes and braces. 

3

Jkoberg

Could you attach a sample file to check this behavior on?

0

Not wanna open a new thread, since its similar.

Want to dissable the auto insert of a comment-end.

/*

Some text

Some more text

-> if this text is there and I add the comment-start and go to the end of the comment an hit enter, automatically the comment-end ist added.

How can I turn this off (since the position really sucks and every f... time I have to adjust it so it costs me more time as it helps).

(I am working in Scala)

0

Since 2019 ... I thought IntelliJ should support my workflow, not hindering it. (And by the way its not exactly the same problem, there it goes with /** ...  which is different to comment anything starting with /*   ... and hitting return somewhere, where automatically */ is added. But I voted it up anyway.)

0

I want to really call out Jkoberg 's comment here.   He really nails it. 

Autocompletion of quotes and braces is infuriating - it is not the kind of help I need - that kind of shallow second-guessing for a trivial keystroke (literally the least-effort action of all possible actions I would take in an editor) virtually ALWAYS leads to frustration and distraction.  At the minimum, it means I have to go backspace and fix the syntax error, and then hit the misfeature again, over and over. 

This is precisely my experience and I don't know of any single person who hasn't spent some time googling (and failing) to find a way around it.   It seriously decreased my productivity until I turned it off and now I'm back because Pycharm had it on by default.  

Laugh if you will but I think this one feature/rollout really cost JB a lot of reputation.  FWIW I've been using IJ since 2001 (if memory serves) and I've rarely had to say that.

I don't mind features I don't want to use, but I really hate them being foist on me with at best a comment in release notes that might suggest how to turn it off.

 

0

@Jetbrains Hi, I am sorry to hear your bad experience with that option. That option was enabled by default a long time ago which won't be listed in any recent release notes.

If you have any questions about how to change some settings of these behaviors and can't find the solution online in a short time, I recommend that you could use the IDE main menu `Help | Contact Support` to contact our support about it and you will get an answer about it soon.

Also, you could try our AI Assistant plugin (https://plugins.jetbrains.com/plugin/22282-ai-assistant) which can help answer these questions.

For example. If I ask “How can I disable the autocompletion of quotes and braces in IDEA?”, it will advise me to check related options in ` Editor -> General -> Smart Keys` for it.

0

Leija,

 

FYI, those option often don’t disable the feature. Thus the frustration. 

0

@Jkoberg I see. I have rechecked your reply and noticed you have this issue for PUML files.

I think you are using a third party plugin named the PlantUML Integration which inserted these automatically.

You could disable it in `File | Settings | Languages & Frameworks | PlantUML | Insert paired (), [], {}, “”`.

Not sure why this plugin doesn't use the general `Editor -> General -> Smart Keys` setting for it instead of having their own setting.

You can report this issue to their issue tracker for it: https://github.com/esteinberg/plantuml4idea

1

Lejia Chen    While appreciate the sentiment, you've missed the point rather completely.    I know it was a long time ago.   For a long time I would have to take a little time out of my day wondering what this new feature might be called so I can turn it off.    Multiply  that by the few dozen other “Features” you guys have foisted on us over the years and you begin to see the frustration.    I'm sure there are things I would like to turn off to this day but I can't figure out what they are called..     Even your example presumes knowing that is called autocomplete  (I think I finally found it by searching for the word pair ..  both times now).    This is a form of bias whose name I have forgotten but could be called expertise bias.  It's obvious because you already know it or about it.  

Turning on new features by default is always a dicey proposition, especially with developers who rely on decades of muscle memory.   That's why we rarely switch tools.

0

How about this:   When the editor uses an activated feature to modify the document, then indicate that in the messages pain ("Autocompleting quote due to setting of…")      That would help us understand what just happened.   Please don't turn it on by default though.

 

0
> How about this:   When the editor uses an activated feature to modify the document, then indicate that in the messages pain ("Autocompleting quote due to setting of…")      That would help us understand what just happened.   Please don't turn it on by default though.

Thanks for the suggestion. Unfortunately, I don't think we will add a feature like this.
This message would be annoying for a lot of users, and also we are trying to reduce showing unnecessary notification to interfere with user when coding.

I agree we have many features in our IDEs, so people might be hard to find the needed ones. Also, we enable some settings because some are really helpful, and most people are fine with these options, but some people don't like them. This is a balance between out-of-box experience and some users' preference.

If you can't find a setting, how is it called in IDE settings, you can contact us via `Help | Contact Support` and the IntelliJ IDEA support team is really happy to help you find the settings.
For this specific case, I think you can use some keywords like `pair` or `quote` to search them in the settings to find them. If the option name is not good, we can improve it too.
0

This auto adding of quote is the most frustrating feature of Webstorm. Webstorm adds extra unneeded quotes and fight me all the way when I try to delete them. New quotes keep popping, like in a wack-a-mole game.

0

The issue is still exists and still frustrating a lot.

Settings at “Editor -> General -> Smart Keys”:

* Insert pair quotes

* Insert pair brackets

* Surround section on typing quote or brace

* Insert pair ‘}’

Not helps to disable this “feature”.

 

 

Example at:

Arina Efremova 

Created July 23, 2020 17:06

I would be happy to see that in my editor as it was a lot of years.

 

Please provide way to disable this “feature”.
---

Even in this editor I MUST enter “” twice before it appear!!!

0

Elfanlide 

Please provide an actual code sample that you are struggling with. What type of file is it?

As before, if I disable the following settings, I'm not getting the issues that you are referring to:

See example for a .css file:

0

Please sign in to leave a comment.