Unable to open pycharm

Hi Team,

While trying to open Pycharm IDE from Ubuntu terminal getting below messages.
Could you please me on the issue?
<<Message>> 
/Downloads/pycharm-community-2020.1.2/bin$ ./pycharm.sh
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
IDE is being shut down

Thanks,
Bikram

1 comment
Comment actions Permalink

IDE is probably started with wrong Java runtime, please ensure IDE is started with the bundled Java runtime located in <pycharm_installation>/jbr

https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under

The first thing you can try is to set PYCHARM_JDK_64 env variable to bundled jbr and try running pycharm.sh again.

0

Please sign in to leave a comment.