Xdebug 2.8 doesn't trigger. PHPStorm 2020, PHP 7.4 on WAMP

I did everything according to manual, read several tips, watched youtube video.

My config seems to be right but Xdebug still remains total silent. No prompt box appears in PHPStrom when I run application. 

When open index of web application, no xdebug is triggered. I post below all my config which seems OK. I Checked:

  • xdebug installed
  • phpinfo() - OK
  • terminal php --version OK
  • port OK
  • IDE key OK
  • Chrome extension OK
  • Breakpoints set OK
  • PHPStorm listens for debug connection

My test index.php just outputs 3. No stopping on breakpoint at all.

5 comments
Comment actions Permalink

Hi there,

To start with:

1) Please show Xdebug section of phpinfo() output captured in the same way as you are trying to debug it (as I understand it's a web page and not a CLI).

2) Enable, collect and share Xdebug log for such unsuccessful debug session.

Also check https://www.jetbrains.com/help/phpstorm/troubleshooting-php-debugging.html

0
Comment actions Permalink

Thank you very much for reply.

I tried troubleshooting but without success. I setup log output file, but no log appears. It feel like I am missing some trigger which actually trigger xdebug. Only noticeable change is when I turn on that Chrome plugin into debug mode, page loads finishes with delay aprox. 2 seconds.  

I tried to switch off firewall + antivirus - no change.

I can add another fail, command "telnet host 9000" actually say that connection failed. But this is from troubleshooting and I am not sure what that command actually does.

I am posting screen of phpinfo() - I even put before phpinfo() breakpoint.

0
Comment actions Permalink

>I am posting screen of phpinfo() - I even put before phpinfo() breakpoint.

I need an actual section, not a header only.

 

Your last screenshot:it shows different info than what your very first screenshot does.

 

P.S. BTW, you cannot run profiler and debugger at the same time: it does not make sense (profiler shows how much time is spent; debugger does the whole thing slowly, step into etc etc).

1
Comment actions Permalink

Oh boy oh boy! Got it! Thank you very much dear sir! Based on your comment, I detaily review "actual section" of xdebug from phpinfo(). Turns out CLI interpret which have have defined in PHPStorm was not using same php.ini as my WAMP...

I was editing C:\wamp64\bin\php\php7.4.0\php.ini (which PHP Storm uses)

But my WAMP was using C:\wamp64\bin\apache\apache2.4.41\bin\php.ini

I just copy pasted config and it worked like a charm!

0

Please sign in to leave a comment.