Unable to accept JetBrains Privacy Policy, I get red box in CentOS7 over RDP

I installed PyCharm using JetBrains Toolbox on CentOS7(CentOS Linux release 7.8.2003 (Core)).

This is a remote dev VM, and I access it over RDP from my MAC with 16bit color quality.

I am unable to accept the license agreement.

 

3 comments
Comment actions Permalink

This is a known issue: https://youtrack.jetbrains.com/issue/JBR-1785

Please try the following workaround: https://youtrack.jetbrains.com/issue/JBR-1785#focus=Comments-27-4143646.0-0

If it doesn't help, feel free to leave comments in the ticket, vote and follow for updates.

0
Comment actions Permalink


I saw 3 options in the above links:

1) I added -Dsun.java2d.xrender=false to the following file:
/home/<username>/.local/share/JetBrains/Toolbox/apps/PyCharm-C/ch-0/201.8743.11/bin/pycharm64.vmoptions :

-Xms128m
-Xmx750m
-XX:ReservedCodeCacheSize=240m
-XX:+UseConcMarkSweepGC
-XX:SoftRefLRUPolicyMSPerMB=50
-ea
-XX:CICompilerCount=2
-Dsun.io.useCanonPrefixCache=false
-Djdk.http.auth.tunneling.disabledSchemes=""
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow
-Djdk.attach.allowAttachSelf=true
-Dkotlinx.coroutines.debug=off
-Djdk.module.illegalAccess.silent=true
-Dawt.useSystemAAFontSettings=lcd
-Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine
-Dsun.tools.attach.tmp.only=true
-Dsun.java2d.xrender=false

But still no luck.

2) Set 24-bit depth on Xvfb: I can see Xvfb is running but I don't know how to change its settings to: Xvfb $DISPLAY -screen 0 1024x768x24

3) Use JBR8: is there a way to change boot java runtime using command line?

0
Comment actions Permalink

Here's additional information on how to change Java runtime: https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under

But using JBR8 in PyCharm 2019/2020 will likely cause other issues, as a lot of features depends on JBR11, e.g. Jupyter/Markdown support.

As for other options, I think it's better to ask directly in the ticket, as I don't have any additional information.

0

Please sign in to leave a comment.