Cannot find declaration to go to: Javscript src is valid [SOLVED]

  • When I Ctrl click on the src directory, it properly takes me to jquery source file.
  • Loading the test page in my browser works perfectly. (body text is "hello world"). No console errors.
  • This behavior started immediately when I upgraded to 2020.2
  • I have tried Invalidate Cache / Restart
  • This happens in my main project, but I have created a totally blank project (see screenshot) and have the same problem
  • Ctrl click on the $ says "Cannot find declaration to go to"
  • I have tried absolute path and relative path
  • I have searched the web and community and bugs and unable to find a solution (except "add to Library")...
  • I DO NOT want to add jquery as a Library, ALL of my javascript include files behave the same way and it is driving me crazy. eg: I might have 2 PHPstorm errors in 2020.1, but have 100+ errors in 2020.2.

 

Any help much appreciated!

3 comments
Comment actions Permalink

Ooops... I this is for PHPstorm 2020.2 (not WebStorm!)

0
Comment actions Permalink

The IDE can't use minified .js files for code completion, it had never worked; please download stubs for this library in Settings | Languages & Frameworks | JavaScript | Libraries: press Download..., type jquery in Download Libraries dialog to locate it

See https://www.jetbrains.com/help/phpstorm/2019.3/configuring-javascript-libraries.html#ws_jsconfigure_libraries_ts_definition_files

0
Comment actions Permalink

Thank you.

0

Please sign in to leave a comment.