2020.2 showing |NBSP|

Hey,

Since the 2020.2 update, PHPStorm is ostensibly showing non-breaking spaces.

I understand this sign can be a pain in the ass in a lot of cases, but the thing is that the non-breaking space is a real thing in french. We call this "espace insécable", they are needed with most punctuations. This is what I see since the update:

I did not find a way in settings to disable this. Can somebody help me?

 

For information I'm on Linux Mint, using JetBrains Toolbox to install and update IDEs.

12 comments
Comment actions Permalink

Hi there,

https://youtrack.jetbrains.com/issue/IDEA-115572 -- this is the original ticket for this functionality.

Sadly I do not see how this new functionality can be configured in any way (or even disabled completely).

I may only suggest you to check that and related tickets for possible comments with workarounds... and if none found just file new Feature Request ticket to the Issue Tracker .

 

Side note: I'm using (used before for many years) Zero-width Character Locator plugin: it is implemented as an inspection (will show an Error mark in such places) and allows to disable particular symbols from been reported. Obviously: it's done differently as it serves a bit different purposes but still: it was possible to customize it.

1
Comment actions Permalink

This behavior can be disabled at Help | Find Action | Registry | editor.show.special.chars.

 
5
Comment actions Permalink

Thanks to you both for your answers.

Eugene Morozov > Thank you, I just did that, it works. Does this setting concern only hidden characters?

Anyway, that was not easy to find, and that's a strange default behaviour. In the original ticket I see people saying that hidden characters do not make sense in an IDE and massively +1, but I'm afraid this is a narrow, english-speaking vision. IDEs are not just about code, they are also used to write user-end texts, including documentations for example. We have to consider that other languages than english exist. As I said, non-breaking space is a real deal in french, and I guess this is not the only case.

I would suggest a less agressive approach, like a clear setting « Show hidden characters », instead of an esoteric registry line. ;p

But thanks again for the quick answer! Have a good day.

A

0
Comment actions Permalink

Anyway, that was not easy to find, and that's a strange default behaviour. In the original ticket I see people saying that hidden characters do not make sense in an IDE and massively +1, but I'm afraid this is a narrow, english-speaking vision. IDEs are not just about code, they are also used to write user-end texts, including documentations for example. We have to consider that other languages than english exist. As I said, non-breaking space is a real deal in french, and I guess this is not the only case.

I suppose we just had no idea that these symbols might matter in languages other than English.

I would suggest a less agressive approach, like a clear setting « Show hidden characters », instead of an esoteric registry line.

Could you please submit this as a usability issue to our tracker? Just in case if there is a lot of people who stumble upon this.
https://youtrack.jetbrains.com/newIssue?project=IDEA

0
Comment actions Permalink

Yeah I wasn't making any reproach, of course. (: I was just developing my point and making a suggestion to help improving an already excellent tool.

I will submit an issue tomorrow, thanks!

A

0
Comment actions Permalink

I have this suddenly everywhere in intellij too. Very confusing and annoying.

0
Comment actions Permalink

how do i turn it off without messing with the registry? 

0
Comment actions Permalink

Unfortunately,  registry tweak is the only way now.

0
Comment actions Permalink

Looks like this is now (Rider version 2021.2) configurable in

Settings \ Advanced Settings \ Editor \ Checkbox for

"Render special characters (control codes, etc) using their Unicode name abbreviations"

7
Comment actions Permalink

thanks, Brian Kowalski, it helps me!

0
Comment actions Permalink

I do not have registry because I'm using a Linux version.
How to turn off NBSP showing all over my code?

0
Comment actions Permalink

@Dbabits2

I do not have registry because I'm using a Linux version. 

1. This does not change anything. It's an internal registry, something like about:config in Firefox.

2. As stated in 2 comments above yours, there is a GUI option for that now.

0

Please sign in to leave a comment.