Webstorm completely crashes when clicking debug on windows since latest update

Using version:

WebStorm 2020.2
Build #WS-202.6397.88, built on July 24, 2020
Licensed to XXXXXXXXXXXX
Subscription is active until September 28, 2020
Runtime version: 11.0.5+10-b520.17 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 1974M
Cores: 12

 

Literally I can 'run' code completely fine, but since I installed the auto update, whenever I click the debug icon, everything just locks up and the window is completely unusable, only way to kill it is the taskbar. I don't even get the highlight on the close button when I roll my mouse over it, its completely and utterly dead.

Not sure if there are any logs somewhere I can attach to help? Equally happy to do a screen share or something to assist. This is incredibly frustrating, having to use my Mac laptop to do any coding (as I need the debugger loads for the current piece I am working on), and I would MUCH rather be using my windows desktop.

Just to confirm it worked completely fine prior to upgrading to latest version, and the code runs fine with the normal run mode. Also its near instant the lock up, with no output in the terminal/run window area

2 comments
Comment actions Permalink

oh wow, I just cleaned my log folder and it appears to now be working, perhaps something funny happened during upgrade? Just need to restart to confirm as something is holding the debug port and its perhaps the crashed process

1
Comment actions Permalink

ok please feel free to delete this ticket. completely clearing old the log folder made everything start working. Although I guess be aware if you see other people struggling, that there may be some kind of issue with the log file folder. Would suggest permissions, but its windows, so that does seem unlikely. And to confirm, multiple restarts were had and I still saw the issue

0

Please sign in to leave a comment.