File extensions not showing in the Find in Path > File Mask

Answered

Hi,

 

In my phpStorm, the File Mask extension is empty and I can not filter the search results by file type (extension). See the screenshot below-

How can I solve this issue?

5 comments
Comment actions Permalink

Hi there,

So even if you tick the "File Mask" checkbox it still shows you the empty list?

Are you able to add your own masks (e.g. "*.php" without quotes)? Will they be remembered on next IDE session?

In either case: https://youtrack.jetbrains.com/issue/WI-54664

2
Comment actions Permalink

Yes, even if I tick the "File Mask" checkbox it still shows you the empty list. And I don't know how to add my own masks. Could you tell me how I can do that.

Thanks

0
Comment actions Permalink

>And I don't know how to add my own masks.

Just start typing there?.. That's how it works for me.

0
Comment actions Permalink

I have the same issue. Even if i type ".js", ".php" (without quote, of course) it doesn't filter (even when you can see a .js and a .php in the list with file mask disabled)

0
Comment actions Permalink

I also can confirm that file masks are empty in 2020.2.3 and here is a ticket about it:

https://youtrack.jetbrains.com/issue/IDEA-236785

 

However, masks could be tricky. Please try *.php instead of .php, that should do work fine.

2

Please sign in to leave a comment.