PHPStorm blocks port 8080

I need to run php server for YII project on the port 8080. But as I see this port is blocked by PhpStorm. I dont understand it. Why PHPStorm use this port? Second question is how to change it or how to stop it? Thanks a lot.

7 comments
Comment actions Permalink

By default, there's nothing configured to listen on port 8080 in PhpStorm. What makes you think it's PhpStorm that occupies it?

0
Comment actions Permalink

If I run this command: Get-Process -Id (Get-NetTCPConnection -LocalPort 8080).OwningProcess

it returns

Handles NPM(K) PM(K) WS(K) CPU(s) Id SI ProcessName
------- ------ ----- ----- ------ -- -- -----------
874 74 1074596 968496 1,222.48 11536 1 phpstorm

0
Comment actions Permalink

Weird. PhpStorm can listen on a port for 1) the built-in web server 2) for the incoming PHP debugging connections.
You can check the port for 1 at Settings | Build, Execution, Deployment | Debugger | Built-in web server,
and for 2 at Settings | Languages & Frameworks | PHP | Debug.

Do you see 8080 anywhere around there?

If you don't, I suppose we'll have to look at the logs (Help | Collect Logs and Diagnostic Data) as I have no other ideas. You can upload the logs here.

1
Comment actions Permalink

Yes settings->Build, Execution, Deploy->Debugger listen on port 8080. But why?

 

0
Comment actions Permalink

Are you 100% sure you didn't change it yourself? The default port is 63342.
It was either you or a 3rd-party plugin, but I never heard of a plugin that would change this particular port.

1
Comment actions Permalink

I realy dont know. So I could change it to 63342?

0
Comment actions Permalink

Yep, that should solve it.

1

Please sign in to leave a comment.