Out of the blue, 283 (!) "Failed to read class" compatibility problems with IU-202.6397.9

I'm trying to update a plugin that I've submitted before as an "alpha" release as an updated "stable" release.

When I first uploaded my update, I soon got a message back that I had an incompatibility problem with 2019.3.5 (IU-193.7288.26) of IDEA, an earlier version.

The error didn't make much sense, as I was able to run my code just fine on that release, nevertheless I changed the code to avoid the NotificationGroup constructor the report called out, and submitted another update.

Now I had a huge number of problems with the latest release of IDEA, 2020.2 (IU-202.6397.94) which I didn't have just yesterday. All of a sudden, dozen of basic IntelliJ API classes were listed with "Failed to read class" errors.

What has changed!? It wasn't a change I made that would have done this!

8 comments
Comment actions Permalink

I just ran the verifier tool myself (as opposed to uploading my plugin, and waiting for an automated response), and I'm not getting all of those previously reported errors, only a small number of deprecation warnings, of which I was previously aware:

kshetline@Baranduin temp % java -jar verifier-all.jar -runtime-dir /Library/Java/JavaVirtualMachines/jdk1.8.0_151.jdk/Contents/Home check-plugin ~/programming_projects/ligatures-limited-intellij/build/distributions/Ligatures\ Limited-1.0.2.zip ideaIU-202.6397.94 
Starting the IntelliJ Plugin Verifier 1.241
Verification reports directory: verification-2020-07-28 at 19.10.04
2020-07-28T19:10:04 [main] INFO verification - Reading IDE ideaIU-202.6397.94
2020-07-28T19:10:10 [main] INFO verification - Reading plugin to check from /Users/kshetline/programming_projects/ligatures-limited-intellij/build/distributions/Ligatures Limited-1.0.2.zip
2020-07-28T19:10:11 [main] INFO verification - Task check-plugin parameters:
Scheduled verifications (1):
com.shetline.ligatures-limited:1.0.2 against IU-202.6397.94

2020-07-28T19:10:12 [main] INFO verification - Finished 1 of 1 verifications (in 0.8 s): IU-202.6397.94 against com.shetline.ligatures-limited:1.0.2: Compatible. 5 usages of deprecated API
Plugin com.shetline.ligatures-limited:1.0.2 against IU-202.6397.94: Compatible. 5 usages of deprecated API
Deprecated API usages (5):
#Deprecated method com.intellij.openapi.editor.markup.RangeHighlighter.getTextAttributes() invocation
Deprecated method com.intellij.openapi.editor.markup.RangeHighlighter.getTextAttributes() : com.intellij.openapi.editor.markup.TextAttributes is invoked in com.shetline.lligatures.LigaturesLimited.EditorMarkupListener.doICare(RangeHighlighterEx) : boolean
Deprecated method com.intellij.openapi.editor.markup.RangeHighlighter.getTextAttributes() : com.intellij.openapi.editor.markup.TextAttributes is invoked in com.shetline.lligatures.LigaturesLimited.applyLigatureSpans(Editor, SyntaxHighlighter, Color, ArrayList) : void
Deprecated method com.intellij.openapi.editor.markup.RangeHighlighter.getTextAttributes() : com.intellij.openapi.editor.markup.TextAttributes is invoked in com.shetline.lligatures.LigaturesLimited.cleanUpStrayHighlights(Editor) : void
Deprecated method com.intellij.openapi.editor.markup.RangeHighlighter.getTextAttributes() : com.intellij.openapi.editor.markup.TextAttributes is invoked in com.shetline.lligatures.LigaturesLimited.getHighlighters(Editor) : List
Deprecated method com.intellij.openapi.editor.markup.RangeHighlighter.getTextAttributes() : com.intellij.openapi.editor.markup.TextAttributes is invoked in com.shetline.lligatures.LigaturesLimited.getHighlightColors(PsiElement, ElementCategory, String, int, int, SyntaxHighlighter, EditorImpl, TextAttributesScheme, Color, List) : Color[]
Plugin can be loaded/unloaded without IDE restart

2020-07-28T19:10:12 [main] INFO verification - Total time spent downloading plugins and their dependencies: 0 ms
2020-07-28T19:10:12 [main] INFO verification - Total amount of plugins and dependencies downloaded: 0 B
2020-07-28T19:10:12 [main] INFO verification - Total amount of space used for plugins and dependencies: 0 B

Could this mean that its just that IntelliJ's automated verification is currently broken?

0
Comment actions Permalink

I also encountered a similar problem, do not know how to solve.
https://intellij-support.jetbrains.com/hc/en-us/requests/2777932

0
Comment actions Permalink

Thanks for letting us know. We're working on that, stay tuned.

1
Comment actions Permalink

My problem has been solved, thank you!

 

 
0
Comment actions Permalink

I'm getting the same issue (800 such errors)

0
Comment actions Permalink

Everything should behave correctly now. In case of failed verification, run it again from the plugin configuration page.

0
Comment actions Permalink

Yep I can confirm it works now.

0

Please sign in to leave a comment.