Clicking a search result in a text file highlighted from the Find box auto-selects the result

This is really annoying, and started happening several updates ago (I'm on the latest).

When I have search results from the Find box highlighted in yellow in the file, clicking somewhere else then clicking onto one of the highlighted results will cause the entire result to be selected, and if I'm trying to highlight a part of it for selection, it ends up dragging the whole selection around, or if I type after clicking it, the text is overwritten.

I don't see any reason to auto-select the whole search result when clicking on any part of it. It didn't used to work this way before; things were just fine in this regard before. Every other editor I use, clicking on a found search result just puts the cursor where I clicked between the characters I clicked between.

Is this an instance of the editor being too helpful? Or is this a bug? I can't imagine any JetBrains developers enjoys this weird feature which requires me to click twice into a found result to edit its text or being selecting a part of it as with any other text.

8 comments
Comment actions Permalink

Sorry, but I was not able to reproduce it, nothing is selected when I just click on the highlighted result.

Am I doing something wrong here? Would it be possible to record a screencast with the scenario illustration?

-1
Comment actions Permalink

Vasiliy, you did everything except the thing I'm having the problem with; click and drag on a find result that is highlighted by Find but not selected from your cursor. In fact, I notice the first time you click on a highlighted result (that you haven't clicked on before), the cursor selects the result then unselects it... just like in my editor, down-click selects the highlighted text, then up-clicking unselects it. This means that a click-drag will select then drag the whole highlighted result around... which is the the main problem I'm having.

Note that "highlighting" is Find turning a search result yellow, and "selecting" is the text turning blue (like when you double-click normal text).

JetBrains have now basically flipped click/double-click behavior in their editor when it comes to highlighted Find results that haven't been interacted with yet, contrary to every other editor I've ever used, including past PHPStorm versions. This has got to be a bug and not intended behavior, as it's confusing and pointless. If it's intentional, then they're not even being consistent with it, because it only happens the first time you interact with the search result. Either way, this behavior is not desirable.

I'm not sure how you made the video, but I'm on a Mac. I made a QuickTime screen recording of a test, but I'm not sure how to get a gif of a video like you did. Please tell me how you did it, or make your own with the proper test of what I'm describing.

 

0
Comment actions Permalink

I also just noticed another bug that causes a similar problem after Find is closed... clicking text that matches the search term will still auto-select it as if the Find box was open with that term in it and the text was still highlighted yellow.

So the bizarre down-click auto-select behavior persists after Find is closed.

I have a QuickTime screen recording of this as well, but I'm not sure how to safely convert it to gif without compromising my computer or my company's files.

0
Comment actions Permalink

Actually, I am using "Screen2Gif" application to record GIF files, it is quite easy to use and it allows to record screen regions:

https://www.screentogif.com/

Also, you may try using RecordIt, it is pretty nice as well:

https://recordit.co/

As for the accidental and unpleasant dragging, could you please try disabling the "Move code fragments with drag-n-drop" option in "Editor | General", does it make things better? 

-1
Comment actions Permalink

Before I let you know the result, will you please tell me if you understood the problem I mentioned, and if you ran into it yourself? It's still there after the latest update, all of the bizarre issues that are not even consistent and some that still happen after the Find box is closed (meaning there's no way these issues are intentional, they make no sense).

Disabling code fragments stops the erratic bug, but it also completely prevents me from dragging selected text, which is now a new problem, because sometimes I want to drag selected text.

Also, do you understand the difference between highlighted text and selected text? Highlighting is Find causing found text to have a yellow background (in macOS theme anyway), and selecting is me double-clicking text.

The undesired auto-select that is happening, that is part of the bug here, is happening on single-click of a Find result (that's already highlighted)... and all of the other bizarre behavior I've described, even after Find is closed.

So there's still no solution here that doesn't cause a new problem, and the behavior either way is not how text editors work normally (at least in every other one I've used). This is a major problem with PHPStorm, and I don't know that anyone is understanding except for my coworker whom I showed it to, and which you can see for yourself if you follow my instructions.

I filed a bug ticket about this, and I'm glad you marked it as a bug (because it is, I don't see how it isn't), but you marked it as a duplicate of a different issue, which is apparent when you read and understand what the two ticket descriptions are saying:

https://youtrack.jetbrains.com/issue/IDEA-248465

I've left a comment clarifying the issue so it's clear that it's not a duplicate of a double-click bug (this one is a single-click bug, specifically on the down-click), and I hope it gets fixed on the next update, because the latest update did not fix it, and it appears the issue is still not understood, and it was hard to figure out what was causing me problems, and hard to explain, and apparently hard to understand. But it absolutely needs to be fixed, it's not how PHPStorm used to behave, or any other editor I use, and it's multiple problems, and has been screwing with me for months.

Thank you.

0
Comment actions Permalink

It appears that the IDEA QA engineer saw your concern about this not being a duplicate of the other issue, and even managed to reproduce it.
https://youtrack.jetbrains.com/issue/IDEA-248465#focus=Comments-27-4367076.0-0
So, the issue is acknowledged, the IDEA team has to fix it. Thank you for being insistent.

1
Comment actions Permalink

Tatiana saw it and reproduced it, yes, after I posted the clarification; Vasiliy has not even acknowledged it.

0
Comment actions Permalink

Note: I've highlighted the important parts below if the amount of text looks intimidating.

One thing I noticed again today (that I'm not sure I should put on the ticket yet) while I was in Chrome (looking up memcache findServer at https://pecl.php.net/package/memcache/3.0.5): when hovering over text for selecting to copy, the mouse cursor stayed as or changed to a black arrow (as opposed to being a capital I symbol), and down-clicking and dragging did nothing... when I clicked in surrounding areas (outside of text) then the normal text cursor came back (the capital I), and click-select worked again.

I now remember seeing this on Macs before in different programs, and then occasionally when dealing with text in different programs. This isn't something I've seen in Windows, or just extremely rarely probably just on very odd circumstances.

I'm beginning to think something about a change in PHPStorm in March or April exacerbated this odd "bug" in Mac, to the point where it's consistent and noticeable enough for me to file a bug ticket about it (which was reproduced by Tatiana, who's probably using a Mac).

So now I'm on the hunt for why the cursor becomes improper (or doesn't change to its proper context) when hovering over text in Mac.

I'm pretty sure the issue existed before I changed any settings on the two Macs I've used since 2 years ago, and the behavior may have started with an update to Mac... I started using this computer (my work computer, a 2017 iMac) in 2018, when it was on Sierra, and my home MacBook (an i5 from 2012) while I think it was on Mountain Lion, but I think the problem on that computer started on an update after that (I'm not sure, I didn't use that MacBook often).

Anyway, it would be nice to know if anyone else has here has run into the weird inappropriate cursor context on macOS while hovering over text... I bet it's related, and I think JetBrains made a change to *Storm that exacerbates the problem (so I think there's two problems: one on Mac and another on *Storm).

I wonder if something in Mac Settings, like Accessibility or Mouse or Language or something else causes the initial Mac issue, and if adjusting that will prevent the *Storm issue... I know I have changed settings in my Macs, but everything looks normal and as expected right now, and I don't have anything unusual or unwanted that I'm seeing there. If someone with some knowledge of Mac settings and cursor context can provide some details of their experience with it, I'm sure people with this issue will appreciate it.

0

Please sign in to leave a comment.