Holding scroll wheel to the side to scroll horizontally only scrolls one tick

Hi,

I just got a Logitech G502 Hero mouse, and when I hold the scroll wheel to one of the sides to scroll horizontally, the mouse only scrolls one tick. I therefore have to push the scroll wheel to the side multiple times to do what I want.

My old mouse was a Logitech Performance MX, and this mouse continuously scrolled horizontally just fine when I held the scroll wheel to the side.

Do you know of any compatibility issues using this feature?

As a workaround, I will use Shift + scroll to scroll horizontally for now, but I'd really like to use the scroll wheel for this so I can do this with one hand.

4 comments
Comment actions Permalink

It seems that it might have a relation to the SetPoint software that Logitech uses for their mice: https://youtrack.jetbrains.com/issue/IDEA-243064

1
Comment actions Permalink

I see you found my ticket regarding my old mouse! I eventually gave up on that one. :)

SetPoint is not installed on my machine, so it can't be SetPoint this time. I am, however, using G Hub (the software for Logitech's gaming products, such as the G502 Hero). Quitting G Hub actually solved the problem, both in PhpStorm and Notepad, which are the two programs I tested. The mouse works exactly the same in both programs: can scroll continuously without G Hub running, and can't when it runs.

That is quite an annoying fix though, as one of the major selling points of the G502 Hero is to be able to use G Hub to make macros and customize the mouse pretty much any way you want. I think I will copy this solution for now, which is to make a macro to repeat the "tilt scroll button" every n milliseconds while holding/tilting the scroll button. That should do the trick. ;)

Once again, Logitech's own software creates problems with horizontal scrolling on their own mice! Ridiculous!

Thank you for pointing me in the right direction, your responses are always blazing fast and on point. Keep up the good work!

0
Comment actions Permalink

I had a suspicion that it might have been yours because of the wording and the name, but the circumstances were different, so I had doubts too.
Thank you for the update!

0
Comment actions Permalink

Hey So found this a couple years later, but I just found the solution on a reddit posting and it worked for me after being annoyed by this same exact thing for years. All you need to do is turn on On-Board Memory Mode in your G HUB mouse settings and horizontal scrolling is back in action. Why it's a thing I'm not sure. Hope this works for you if you haven't found a solution yet.

0

Please sign in to leave a comment.