Run/Debug Configurations freezes RubyMine with blank page




I recently updated Rubymine from 2019.2 to 2020.2. 

After the update, any time I try and open Run/Debug Configurations, I get a frozen empty window and my whole ide freezes. Force kill RubyMine is the only way I can get out.

I've tried a couple things without much luck(I downgraded to 2020.1.4, but saw the same issue, I wiped out my .idea project and tried a fresh start, and I've tried disabling a few of my plugins.)

Any ideas on what else I could try? I'm gonna try disabling all plugins entirely, and also wiping out .idea project to see if that works.

Comment actions Permalink

Okay... disabling literally every plugin seems to have fixed things. I guess I'll try turning them back on to see what the culprit is.

So weird. I re-enabled the plugins slowly, and everything continued working even when I re-enabled all of them. 

Comment actions Permalink


thank you for sharing your solution. In case the issue comes back, please let us know.


Please sign in to leave a comment.