Getting "t.rvm.RvmVersionManagerHandler - Error getting rvm environment " on RubyMine 2020.2.1

Hi,

When I try to launch  

$ ./rubymine.sh

 

2020-09-02 11:34:41,272 [ 6998] WARN - t.rvm.RvmVersionManagerHandler - Error getting rvm environment
java.lang.RuntimeException: malformed:======================================================================
- Release.....: Red Hat Enterprise Linux Workstation release 7.6 (Maipo)
- Users.......: Currently 1 user(s) logged on
==================================================================
- Manufacturer:................: LENOVO
- Machine Type:................: 20EQS64N0B
- Machine Model:...............: ThinkPad P50
- Serial Number:...............: Only accessible by root
====================================================================
- CPU usage....................: 0.83, 0.49, 0.43 (1, 5, 15 min)
- Memory used..................: 2730 MB / 31387 MB
- Swap in use..................: 0 MB
- System uptime................: 0 days 0 hours 27 minutes 48 seconds
- Disk space Root..............: 24G remaining
- Disk space Home..............: 129G remaining
================================================================================
XDG_VTNR=1
at com.intellij.util.EnvironmentUtil.parseEnv(EnvironmentUtil.java:355)
at org.jetbrains.plugins.ruby.version.management.rvm.RvmVersionManagerHandler$RvmEnvironment.compute(RvmVersionManagerHandler.java:186)

6 comments
Comment actions Permalink

Hello,

could you please attach the output of 'rvm list' command? Do I understand it right that the list of SDKs in Settings is empty?

1
Comment actions Permalink

Thats what was not clear, why it was giving this error when the sdk is present

 

$ rvm list
=* ruby-2.6.5 [ x86_64 ]

# => - current
# =* - current && default
# * - default

 

0
Comment actions Permalink

According to the screenshot Ruby hasn't been detected automatically, have you added it manually?

1
Comment actions Permalink

Can you explain what you mean by "added manually"?

    When I set up the project, I went to settings and added the SDK the first time. After that it is been there in the workspace.

0
Comment actions Permalink

I mean that in case it's a local rvm then it should be detected automatically. 

Could you please add the following lines to Help | Diagnostic Tools | Debug Log Settings:

#org.jetbrains.plugins.ruby.version.management.rvm.RvmSdkRefresher
#org.jetbrains.plugins.ruby.ruby.run.RubyCommandLine
#com.intellij.execution.configurations.GeneralCommandLine

then restart IDEA and attach idea.log (Help - Show log in). You can send it also to rubymine-support@jetbrains.com

1

Please sign in to leave a comment.