17 comments
Comment actions Permalink

this is my package.json

0
Comment actions Permalink

Is the first error ("Please specify path to 'eslint' package") solved?

0
Comment actions Permalink

I have the same issue

-4
Comment actions Permalink

Have you tried to install eslint globally and restart your IDE?

npm install --g eslint

17
Comment actions Permalink

Thanks Ali Sedighi, this fixed the error for me!

0
Comment actions Permalink

First, run `npm install --g eslint` on the terminal to install the package globally.

Make sure that the ES Lint settings are set to Automatic ES Lint Configuration

Now restart the IDE and see if the error disappears 

4
Comment actions Permalink

Thanks Mutua Chris, that fixed it for me!

0
Comment actions Permalink

Thanks Muta Chris - that solved the issue

0
Comment actions Permalink

i tried the same and it still complains saying please specify a path....

0
Comment actions Permalink

Thanks Mutua Chris! That fixed it for me.

0
Comment actions Permalink

Installing ES Lint globally didn't work for me.

My problem was that the wrong version of Node was selected in my project settings.  I selected the right version of Node and the problem went away.

1
Comment actions Permalink

remove node_modules and run install script

2
Comment actions Permalink

Installing eslint globally with yarn and restarting IDE resolved the issue

yarn global add eslint

 

0
Comment actions Permalink

The solution to this problem shouldn't have to be installing `estlint` globally. If `eslint` is installed in the project locally then the IDE should be able to find the path to it.

2
Comment actions Permalink

Installing ESLint globally is not actually recommended. If local package is not detected automatically, try changing the configuration to Manual and specify the package path explicitly.

If this doesn't work, check your Node.js preferences in Settings | Languages & Frameworks | Node.js

1

Please sign in to leave a comment.