rake/rails tasks via "Run Anything" doesn't always show dialog

Answered

When I run a rake/rails task via the "Run Anything" dialog, I inconsistently get a dialog with prompts where I can specify certain parameters for the task. For example, some migration commands will result in a dialog where I can select which specific migration to use. But, I don't understand when I'll get that dialog and when I don't. I sometimes assume I'll get the dialog and be able to specify an option of some kind, but then end not getting it and the command will run, sometimes with default parameters I didn't intend.

Can I get some information about what determines when that dialog will appear?

3 comments
Comment actions Permalink

Hello Daniel,

you can check our documentation that describes the way commands are matched in Run anything dialog:

https://www.jetbrains.com/help/ruby/running-anything.html#running_ruby

In case it still doesn't work as expected, could you please provide more details about what you're running (screenshots would be also helpful).

0
Comment actions Permalink

I think the issue might just be that RubyMine doesn't fully support running rake tasks using the 'rails' command instead of rake.

For example, if I use the Run Anything dialog to to run 'rake db:migrate', it prompts me with a dialog which allows me to optionally choose a migration or environment:

 

But if I run 'rails db:migrate' (instead of using 'rake'), which I believe is functionally equivalent, I don't get that dialog, and the command is run with (I assume) default parameters.

It'd be nice if RubyMine recognized that those commands are essentially the same, and provided the same experience between the two.

 

Thank you!

0
Comment actions Permalink

Daniel,

we have a corresponding request on our tracker for supporting that so could you please add your vote there: https://youtrack.jetbrains.com/issue/RUBY-25250

0

Please sign in to leave a comment.