WebStorm refusing to stop at many breakpoints while debugging Jest tests in IDE

Today, I cannot convince WebStorm to stop at many of my breakpoints when I'm debugging Jest tests.

Current WebStorm version: 2020.2.1.  What other versions you want?

My workflow is, I have a test file open, and I right-click in the gutter and select "Debug 'the test name'" from the menu:

I have breakpoints in the test file, and I also have breakpoints set in my application source code.  WebStorm will stop at the breakpoints that are in the test file itself, and a *few* of the breakpoints in source files, but not all.  The breakpoints have checkmarks.

I will attach a video of this happening - Upload id: 2020_09_09_YVdibHQvMVpuC8ra (file: webstorm_not_stopping.mp4)

I have stopped and restarted WebStorm, rebooted, and upgraded Webstorm to 2020.2.1 (from 2020.2.0) today, and nothing has affected the situation.

Thanks,

Eric

4 comments
Comment actions Permalink

please check your jest.config.js - what does it look like? Do you have collectCoverage enabled in it?
If the source file is instrumented for coverage, the generated code can't be correctly mapped to source; it's a well known limitation

0
Comment actions Permalink

We don't have collectCoverage enabled, and I'm not running "with Coverage" (I'm debugging).  We did have collectCoverageFrom defined for jest in package.json, but taking that out didn't help matters.

0
Comment actions Permalink

This is crippling my productivity.  No ideas?

0
Comment actions Permalink

Could you share a project the issue can be repeated with?

0

Please sign in to leave a comment.