Anyone else having blade syntax highlighting problem?!

After updating to

PhpStorm 2020.2.1

Build #PS-202.6948.87, built on August 27, 2020

I lost laravel/blade syntax highlighting ... everything else seems working just fine though!

I would appreciate you sharing the solution or the problem if you're facing the same issue.

And yes I have tried enabling/disabling/reinstalling the laravel plugin. I even purchased a paid laravel plugin.

Also I have invalidated caches/restarted several times .. the results are still the same!

Here is what my blade files started to look like (before the highlighting worked perfectly now its defaulting to just one color)


Well, it could sound too obvious but do you have a built-in Blade plugin enabled?



Yeap! first thing I looked... it's driving me crazy


Is it reproducible even on a brand new project?

Please try to create a new project and some test file with a new name like "test.blade.php", will it behave the same?


Just in case, I have double-checked the highlighting on my 2020.2.1 installation without any extra plugins installed and it is working like a charm.


Just created a brand new project with a single 'test.blade.php' still the same. 

I tried before disabling all laravel plugins restarted, then enabled and restarted again, I have tried with different color schemes including Dracula ... I have no idea what to do next! 



It's definitely your setup...

1. Please compress and share the .idea folder for such project -- maybe it will be some project setting

2. Please share your idea.log file (Help | Show Log in ...) -- it may also give some hints.

3. Please disable Material UI Theme plugin, restart IDE and make screenshot using Default (Windows 10 Lights / IntelliJ Light) color scheme -- it may also give some hints (as I'm more familiar with default colors)

4. Place caret on such .blade.php file in the Project View panel and invoke Ctrl+Q (View | Quick Documentation) -- show the screenshot of that.


I want to thank you all for your efforts I appreciate that...

This issue took more time than it should ... I should have simply performed a clean reinstall from the beginning instead of trying to figure out what went wrong.

For anyone running into the same issue .. just doing a clean reinstall (delete phpstorm left over folders after uninstall) should solve this issue... it worked for me anyway.





Please sign in to leave a comment.