Unable to see the image window when I use cv2.imshow()

I just started using pycharm and was trying to open an image file through it. I am unable to find the window which displays the image. 

Please help. 

This is what the output looks like:

7 comments
Comment actions Permalink

Hello, 

 

The error looks more code specific rather than IDE. As an isolation test, could you please run the script out of PyCHarm in cmd with the same interpreter, will you get the same result? 

0
Comment actions Permalink

Hi, I have the same issue after updating macbook to Big-Sur. 

Window doesn't open but I don't get any error messages

4
Comment actions Permalink

Mahmou6

I have the same issue, did you find a solution? I am on the m1 chip MacBook and for me the window does not pop up nor do I get any error messages. 

2
Comment actions Permalink

I worked for me later. Check for a missing library to get your code to run

0
Comment actions Permalink

I am having the same problem on my MacBook. I upgrade my system into macOS Big Sur and my code doesn't generated the image anymore. I also don't get any error at the output. I also have all the libraries included. The code that I'm running was running fine before installing Big Sur. Anyone has any idea what I can do to solve this issue? 

0
Comment actions Permalink

Eziaeika

Try with another interpreter. E.g. create a virtualenv, install the required packages, and see if it works.
Sometimes macOS update breaks system interpreters so if you are using one it may be the reason.

0
Comment actions Permalink

Hello dear , have you solved the issue, if yes please let me know I have the same issue.

0

Please sign in to leave a comment.