Plugin build fails on IJ 2020.2.3 EAP

Answered

Hi

Trying to build our plugin using IJ EAP on JDK 1.8 results in the following failure:

bad class file: /Users/shaia/.gradle/caches/modules-2/files-2.1/com.jetbrains.intellij.idea/ideaIU/LATEST-EAP-SNAPSHOT/a538cfd3bb4bdddc72cf6094471ad8229905b446/ideaIU-LATEST-EAP-SNAPSHOT/lib/platform-api.jar(com/intellij/openapi/editor/Editor.class)
class file has wrong version 55.0, should be 52.0
Please remove or make sure it appears in the correct subdirectory of the classpath.

If I build using JDK 11 it works fine. However according to this I should be able to compile with 1.8 (in fact I need to if I want to support previous versions).

Building against latest non EAP version using JDK 1.8 also works fine.

Can you tell what am I doing wrong?

 

2 comments
Comment actions Permalink

Use Java 11 for compiling the plugin, but set the 1.8 as a target:

sourceCompatibility = "1.8"
targetCompatibility = "1.8"
0
Comment actions Permalink

Oh, that's actually what I did.

Thanks very much for the quick reply.

0

Please sign in to leave a comment.