Upgrading from 2020.1 to 2020.2 is saying my plugin is incompatible, not offering an update.


I am building my plugin for multiple major versions of IntelliJ [1] and publishing these to the same channel. For each major version of IntelliJ, I'm specifying all subversions as being compatible (e.g .201 - 201.*). I'm not targetting any lower/higher as I am using different compatibility APIs depending on the major version of IntelliJ to avoid issues with using APIs changed between those versions.

I'm also now building my plugin with IntelliJ Ultimate, as the plugin is optionally dependent on the microservices API to integrate with the Endpoints tool window. Those APIs are only used from the EPs included when the microservices plugin is present.

I've had reports that when Upgrading from IntelliJ 2020.1 with version 1.7-201 of my plugin to IntelliJ 2020.2, then IntelliJ is reporting that my plugin is incompatible instead of offering an upgrade, even though 1.7.2-202 is available. NOTE: The Update option is provided if the version has changed but the compatibility is the same, such as from 1.7.1-202 to 1.7.2-202.

How do I get IntelliJ to detect a version of my plugin is available with a different compatibility range after upgrading IntelliJ? Is this a bug in IntelliJ?

[1] https://plugins.jetbrains.com/plugin/8612-xquery-intellij-plugin/versions

1 comment

Hi! The problem is that IDE considers 1.7-201 greater than 1.7.2-202. You can use com.intellij.ide.plugins.VersionCompareTest to check how IDE compares versions. We can fix it in later releases of IDE, but unfortunately you would need to release plugin update with version 1.8.x to make already released IDEs notice update over version 1.7-201.


Please sign in to leave a comment.