Find in Path does not work properly

I am using Find in Path (Directory) feature very often. Today, I found out that it does not work properly. The string I was looking for appears in at least 10 files but PyCharm Find in Path features showed only 9 of them. Then, when I checked the folder of the missing file, I found an interesting bug. When I paste the entire string, it can not find the string. However, when I copy a part of the string, it shows me the result correctly. Then I tried to type the rest of the string and it showed me the same result until I removed one character. That is the most interesting part that when I removed a character, the result disappeared. I hope it gives a clue to detect the problem. Can you please help me to figure out and solve this problem? Making the Find in Path (Directory) feature work properly is very important for our project.

You can find 2 screenshots below. I recorded a short video but I don't know how I can share it here without uploading to an external platform.

 

 

 

IntelliJ IDEA 2020.2 (Professional Edition)
macOS 10.15.7

1 comment
Comment actions Permalink

Hello, 

 

Please file an issue here

https://youtrack.jetbrains.com/issues/PY with attached simplified project example, screencast and steps to reproduce the behaviour. 

 

Thank you!

 

0

Please sign in to leave a comment.