Built-in terminal not working properly


My built-in terminal on IntelliJ is not working as expected. I recently got a new laptop and installed Fedora on it, and migrating everything from my old Linux laptop to my new one. However, the terminal is the one thing that doesn't seem to be working. 

Specifically, when creating a new terminal instance, instead of reading my .bashrc like my old laptop used to do, the name is sh-5.0$. I have to run source ~/.bashrc to get my usual terminal environment working, but even then certain commands like mvn aren't found in the terminal.

Why is this happening? I have identical settings to my old laptop and that runs it fine. How can I fix this?


Hi. Please provide a screenshot of Preferences | Tools | Terminal.



I found the cause of this issue to be Flatpak; it would run in a sandbox and therefore did not reflect the actual environment it was being run in. 



Did you find a solution for this ?


Hi, I have same issue withthe IJ flatpak installation not recognizing the correct gnome-terminal.

Not only does this result in terminal limitations (the environment is lost), but this also make the installation of IntelliJ's command-line launcher impossible -> see here:

So, as flatpak users, what can we do about it ?




Jörg Winter

Flatpak is not an official distribution channel so I don't think we can properly troubleshoot it.

We recommend installing IntelliJ IDEA on Linux either extracting the tarball or through snap.

Have you considered using snap or maybe even Toolbox instead of flatpak?


yep, since unfortunately snap is not supported on my Linux Distribution, I will use the tarball.. should work :)


Please sign in to leave a comment.