Pycharm project files not appearing on macOS Catalina

For the last several months, I have been unable to use PyCharm because of an issue where my project files are not appearing in the project structure. When a project is opened or created, the correct project structure and files will briefly appear. However, the file structure will almost immediately disappear, replaced with a "Nothing to show"  under the project tab. 

 

The above example was after generating a new project creating a new environment with the default python interpreter. I have also tried with an anaconda installation, and the results are exactly the same. The issue happens whether creating a new project, opening an existing project, using a new environment, or choosing an existing environment. The issue also happens when opening a single python file to edit. 

Interestingly, the only way that the file structure will appear again is when a new project is opened, and the window appears asking whether you would like that project to be opened in a new window or the same window. The image below shows the reappeared project structure when the "open project" window is open. As soon as an option is selected, however, the project structure reverts back to "Nothing to show" 

 

 

I have tried everything I can think of. The issue exists on both the Pycharm Professional and the Pycharm CE IDEs. I've reinstalled both versions, and reset all the settings to default. I've uninstalled anaconda and reinstalled it. So far, nothing has worked. 

I love the PyCharm IDE, but obviously it is not usable with the given issues. Any help would be greatly appreciated. 

5 comments
Comment actions Permalink

Before someone asks, here are my project settings. The issue exists whether or not "Show Members" or "Show Excluded Files" are checked

0
Comment actions Permalink

Hello, 

 

Please upload your logs folder zipped from ***Help | Collect logs and Diagnostic Data***   to the FTP

https://uploads.jetbrains.com/ and please let me know the filename. 

0
Comment actions Permalink

Antonina Belianskaya I was having the same issue, and search results were pointing to totally irrelevant Interpreter reconfigure which was very frustrating. However, I just resolved this as I remember only during my first install it asked me if it could view Document, Desktop, and Download Folders, hence it doesn't know of our files because of that. 

To Fix this, let's say if your project is in Documents Folder. Go to Mac's System Preferences -> Security & Privacy -> (under privacy tab) select "Files and Folders" from the left side icons.  Under PyCharm click Documents (giving Pycharm access to your Documents folder / if your project is there (different folder otherwise). 

Wallah, all my Files, and Folder appeared after restarting PyCharm. 

 

Hope that Helps. Cheers.

 

1
Comment actions Permalink

Hello Usman Sa, 

thank you very much for sharing this! 

0
Comment actions Permalink

Thank you Usman Sa -- insanely frustrating to get a fresh pycharm license, then burn 2 hours of troubleshooting while the files flicker and disappear in pycharm. Surprised that Jetbrains hasn't put in a notification for this like every other app.

0

Please sign in to leave a comment.