Disable subquery closing bracket indentation

Answered

Sometimes I have a simple query like this:

 

SELECT

  dim,

  COUNT(*),

FROM abc

GROUP BY

  1

 

and then I wrap it in another select. I managed to disable auto format on closing ) in a query like this:

 

SELECT

  *

FROM (

   <subquery>

  )

 

but the closing bracket is still indented. How do disable it?

4 comments
Comment actions Permalink

Hello Dawid,

you can configure this style using the following settings:

  • Queries / Common / Align section elements → off
  • Queries / Subquery / Place the closing parenthesis → unindented

 

 

1
Comment actions Permalink

Ohh thank you so kindly Leonid.. Finally I don't have to reformat my subqueries :D

0
Comment actions Permalink

You can disable auto-format, turning off a couple of options as on the screenshot below:

 

1
Comment actions Permalink

Perhaps you can help me with this one last bit:

 

It creates an indent when I put a comma at the end of the CTE. Not sure which section I should look for it in the Editor settings

0

Please sign in to leave a comment.