Unable to build remote makefile project in 2020.2.4

Answered

I tried many different ways to create a Makefile project with CLion client on Windows, project to be built on CentOS. I watched some videos, tutorials and posts to help, but nothing solved the problem

The final steps I did:

  1. Copy the source files from the server to a local directory
  2. Opened the Makefile in local dir E:\RemoteWork\... as project
  3. Created deployment configuration and added mapping for local and remote directory (this works as upload woprks fine)
  4. Created Toolchecin for remote linux system (works, and all tools are detected)
  5. Set Makefile in settings to use this remote toolcheain, targets all and clean
  6. Created a run/debug configuration using Makfile-Application template
  7. For this configuration created a custom taget Makerfile targets all and clean
  8. Add ed upload command before build in this config

 

First strange thing to me is that just doing "Build" of the new configuration does not upload the files, but immediately build. If I run the program it first complains that I did not set any executable (which I could not as it does not exist and would be remote) But telling it to continue anyway it uploads this time the files and starts make. But it looks like it does locally:

====================[ Build | all ]=============================================
make --jobs=9 all
bash: line 0: cd: E:/RemoteWork/CLion/TIC/aspell-0.60.8: No such file or directory
make: *** No rule to make target 'all'. Stop.

Process finished with exit code 2

 

My first thought was that make was still run locally, but checking with Linux accounting I see that it seems to be executed on the remote system actually but it looks like the local (Windows) path is used to go to the Make file, which results in target "all" not to be found, which is actually because no Makefile is found in login dir.

4 comments
Comment actions Permalink

Ok, in research for another problem I stumbled over a note in the documentation stating that remote Toolchains are not yet supported (while they can be selected), which is a pity as on Windows remote development on Ljnux is probably the main target for Makefile projects.

0
Comment actions Permalink

Hello!

It's not supported yet, unfortunately. Feel free to comment or upvote https://youtrack.jetbrains.com/issue/CPP-20695 in order to get updates. See https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications if you are not familiar with YouTrack.

0
Comment actions Permalink

Hello Anna, thanks to pointing me to that, but the first link yells "Nope, can't find it" to me (error 404). 

0
Comment actions Permalink

Sorry. I corrected the link.

0

Please sign in to leave a comment.