Ctrl-C empty line (linux)

Answered

I just switched from OSX to Linux and there is a minor difference that has a huge impact on my productivity.
When I by accident hit [Ctrl-C] instead of [Ctrl-V], my clipboard is empty and I have to start wasting time with [Ctr-Z]'s

There is no use-case/benefit for this behavior, if I want to insert/paste an empty line somewhere... I hit [Return].
If you check other editors and applications, they all understand this.. you can't copy an empty line, those strokes are simply ignored.
Again, on OSX Jetbrains also understand this, it seems something Linux specific.


Is there any way to avoid this from happening?,.. it really drives me nuts.

 

 

PS. This goes for all apps in your suite, not just PyCharm...

6 comments
Comment actions Permalink

Hello,

Invoke Help | Find Action... (Ctrl (Cmd on Mac)+Shift+A), type "registry", and select the Registry... item that appears. Enable the editor.skip.copy.and.cut.for.empty.selection option there.

Be careful with the other configuration options, because it is possible to break your IntelliJ IDEA installation with an incorrect setting.

1
Comment actions Permalink

AWESOME, problem solved.


Thanks for your fast reply!

1
Comment actions Permalink

CLion does not have nor follow this setting, yet the other editors seem to do so.
Is there any change to make CLion work correctly? 

0
Comment actions Permalink

Hi! This option was changed and now it's located in `Settings/Preferences | Advanced Settings`. Please enable it there:

1
Comment actions Permalink

Awesome, thanks!

0
Comment actions Permalink

For the love of all that is good on Mother Earth, can you please disable this really very daft functionality by default? I can't see why anyone would want this.

Every time I reinstall OS, buy a new PC, reinstall PyCharm, etc, I have to search the web for this ruddy "fix".

0

Please sign in to leave a comment.