Unknown error Message while building Android Studio plugin

Answered
I’m currently developing a plugin for android studio. I’ve added this config to add plugins in build.Gradle.kts
intellij {
pluginName = "MyPlugin"
version = "201.8743.12"
type = "IC"
setPlugins("java", "android", "org.jetbrains.kotlin:1.4.20-release-Studio4.1-1")
}
and these depend on tags in plugin.xml
<depends>com.intellij.modules.lang</depends>
<depends>com.intellij.modules.java</depends>
<depends>org.jetbrains.android</depends>
<depends>org.jetbrains.kotlin</depends>
Whenever I’m trying to build the plugin, I’m getting the following error messages.
The Kotlin (id=org.jetbrains.kotlin, path=~/Projects/AndroidStudioPlugin/build/idea-sandbox/plugins/Kotlin, version=1.4.20-release-Studio4.1-1) plugin requires "com.intellij.modules.androidstudio" plugin to be installed
The Android (id=org.jetbrains.android, path=~/.gradle/caches/modules-2/files-2.1/com.jetbrains.intellij.idea/ideaIC/201.8743.12/da9095e6ac3581f0463f7ae0ebb155647ca427ad/ideaIC-201.8743.12/plugins/android) plugin requires "Kotlin" plugin to be enabled
The MyPlugin (id=com.plugin.studio.myplugin, path=~/Projects/AndroidStudioPlugin/build/idea-sandbox/plugins/AndroidStudioPlugin, version=1.0-SNAPSHOT) plugin requires "Android" plugin to be enabled
The MyPlugin (id=com.plugin.studio.myplugin, path=~/Projects/AndroidStudioPlugin/build/idea-sandbox/plugins/AndroidStudioPlugin, version=1.0-SNAPSHOT) plugin requires "Kotlin" plugin to be enabled
Though the plugin is created successfully and can be installed I fear it might be broken. I also added the following line but same error message. Although adding the following line is marked as an error by the IDE.
<depends>com.intellij.modules.androidstudio</depends>
1 comment
Comment actions Permalink

You are compiling with Kotlin plugin version targeted at Android Studio _only_ ("1.4.20-release-Studio4.1-1"). It is by definition not compatible with IntelliJ IDEA.

0

Please sign in to leave a comment.