Intellij doesn't recognize the file type


I'm using Intellij Idea 2020.3 Ultimate Edition on macOS.

When I create a html file named 'createItemForm.html', Intellij doesn't recognize it is a html file.

When I create another 'createItemForm.html' file in another path, it isn't recognized too.


The source code of 'createItemForm.html' is shown below.


All html files except that name are recognized.

Could you tell me what's wrong with my Intellij?


Can you show the Preferences | Editor | File Types | HTML settings pane:

Does it help to reset settings via File | Manage IDE Settings | Restore Default Settings?


Thank you for the answer.

I solved it by resetting.


adding *.html solved my issue. weird the IDE does not have it by default.



nisim joseph

It does. If you don't have the extension in the list of patterns for the file type, it must have been removed from there e.g. by some custom plugin. Resetting the settings as per the first comment here should have helped in your case too.


Please sign in to leave a comment.