Error scala no scalac found to compile scala sources

IntelliJ Bug: Scala 145, Error:scalac: Scala compiler JARs not found , In project settings, you need to manually add: JDK Folder. Module and dependencies to JDK AND Scala JAR. In library, Add MANUALLY the JAR of Scala (IntelliJ does not add those JAR. Looks as though you have bound the Scala compilation to the process-resources phase to me. The output about no sources is from the regular maven compiler plugin that compiles Java.

Intellij run error: scalac: No 'scala-library*.jar' in Scala compiler , I get this error: Error:scalac: No 'scala-library*.jar' in Scala compiler classpath in Scala SDK scala-library-2.12.6-sources.jar when trying to run a  "Error:scalac: No 'scala-library*.jar' in Scala compiler classpath in Scala SDK SBT: org.scala-lang:scala-library:2.11.10:jar" Without touching the default build.sbt file (leaving it just as it was when I created the project using the wizard), I create a package called "org.public_domain".

With IntelliJ 2017.02.5, receiving error "Error:scalac: No 'scala-library , Creating a brand new Scala SBT project using IntelliJ 2017.2.5 is producing the following error when I attempt to compile a very simple: "Error:scalac: No '​scala-library*.jar' in Scala compiler classpath in Scala SDK SBT: org.scala-lang:​scala-library:2.11.10:jar" Scala: Scala 2.11.10 (Sources checked)  I found two solutions to the similar problem I am facing on web , do they apply to my code ? 1- Import implicits: Note that this should be done only after an instance of org.apache.spark.sql.SQLContext is created.

 

 

MyGroundBiz.com

3 comments
Comment actions Permalink

Error scala no scalac found to compile scala sources Follow. IntelliJ Bug: Scala 145, Error:scalac: Scala compiler JARs not found , In project settings, you need to manually add: JDK Folder. Module and dependencies to JDK AND Scala JAR. In library, Add MANUALLY the JAR of Scala (IntelliJ does not add those JAR. 

Mygroundbiz

0
Comment actions Permalink

In the more recent versions of IntelliJ (2020.1.1) at the time of writing this, I was able to solve this problem by removing the Scala SDK configured in the Global Libraries section in IntelliJ and hitting File > Invalid Caches / Restart.

I'm not sure why this solved the issue, perhaps recent versions of the IDE now have automatic detection of Scala compiler JAR files from Maven (which I'm using to build my project). 

Mygroundbiz

0
Comment actions Permalink

Error scala no scalac found to compile scala sources Follow. IntelliJ Bug: Scala 145, Error:scalac: Scala compiler JARs not found , In project settings, you need to manually add: JDK Folder. Module and dependencies to JDK AND Scala JAR. In library, Add MANUALLY the JAR of Scala (IntelliJ does not add those JAR.

 

McDVOICE

0

Please sign in to leave a comment.