Unable to enter backslash

Hello,

Since WebStorm 2020.3.1, I'm unable to enter backSlash with Mac french keyboard. I use Shift+Option+/  and it worked...but now, it depends on cursor position and enter "return", "div", or something else....
As inverted quote already did not work (and does not seems to be fixed someday), then now \ not working....editor seems to become quite difficult to use.... 

Could you please try to use your product with french Mac keyboard  or give some help for that ?


7 comments
Comment actions Permalink

Hi there,

https://youtrack.jetbrains.com/issue/IDEA-258227#focus=Comments-27-4620777.0-0

Please try the following workaround: Delete the keymap assignment in preferences: Keymap -> MainMenu -> Code -> Code Completion -> CyclicExpandWord (Backward) (right-click -> remove)

 

3
Comment actions Permalink

Must be caused by Use Option as Meta key in Preferences | Tools | Terminal. It has been added in 2021.2 and it's on by default. Just disable it to be able to type characters with Option+key.

1
Comment actions Permalink

I have the same problem, and deleting both the CyclicExpand shortcuts did not help, sadly.

Besides that: Backslash is not the only problem, also ` {}[]`.

This is only an issue in the terminal, but extremely annoying.

When typing `/\()` in the terminal, I get `/((((((()` - so `\` seems to somehow repeat the `(` 7 times. Fun fact: `\`is located on the `7`.

Any suggestions?

PhpStorm 2021.2
Build #PS-212.4746.100, built on July 28, 2021

0
Comment actions Permalink

Nik what OS is it, what system keyboard layout do you use?

0
Comment actions Permalink

Hi Elena,

I'm on MacOS Big Sur (ver 11.4). Keyboard layout is Danish.

0
Comment actions Permalink

PS. I use the IdeaVim plugin, but also tried to disable this.

 

0
Comment actions Permalink

Excellent - that's it! Thank you :-)

0

Please sign in to leave a comment.