Jump to source code (F4) not working

Answered

I apologize if this is a no-brainer but I just switched to Intellij 2020.2 Community edition (from NetBeans) ... I got most of the stuff working now and am quite happy. But when there's an exception at runtime, I get nothing that helps me at all - no stack trace, no information on the location in the sources, no option to to jump there ("Jump to source (F4)" is greyed out) so I just have the exception message. This can't be the expected behaviour as this is so fundamental to development, I'm missing something. 

After 2 hours browsing the web in vain I give up ... can anyone please help? 

5 comments
Comment actions Permalink

Please share the screenshot showing the exception output in the Run console and the location of the file in the Project View referenced from the exception.

A sample project/video of the problem may also help to understand the issue: https://uploads.jetbrains.com.

0
Comment actions Permalink

Thanks a heap for the quick response ... I stumbled over the correct approach by accident as it seems:

first pic: run console with just the exception text (middle window)

second pic: tried the "Jump to Source" on the left, greyed out

third pic: accidentally clicked on the root node of the run on the left -> stack trace appears in the middle plus the option to jump to the source code where the problem occurred. D'oh!

 

"Jump to source F4" is still disabled, but the status now is MUCH better ... as I suspected, a rookie question. Coming from NetBeans I had a difference UX expectation but that's of course ok this way. 

 

 

0
Comment actions Permalink

You can disable Gradle run delegation to run the app directly and see the full stacktrace: https://i.imgur.com/HpeUaUE.png.

0
Comment actions Permalink

ok, thank you - I made the changes in the config.

I'm not sure tho about the effect this is supposed to have ... maybe I'm starting the run in the wrong way:

Shift-F10 seems to start Gradle as before ... which is ok since I can get to the error, the stack trace and jump to the source.

When I go for Alt-Shift-F10 this pops up

and when I go for "Run" pretty much the same thing happens. 

In any case, "Jump to source F4" does not work (still grayed out) ... not a killer problem since I can jump via the window in the center, but still a bit strange.

 

0
Comment actions Permalink

You need to create Application Run configuration instead of Gradle.

0

Please sign in to leave a comment.