Unable to resolve langauge sql or plpgsql

I am using IntelliJ Idea 2020.3 with database tools (same as Datagrip I guess) but even though my dialect is selected as "PostgreSQL" I keep getting the following error in the IDE:

Why is IntelliJ unable to resolve language sql or plpgsql? It should just recognise it as a language declaration right? If I run the SQL code it runs fine.

8 comments
Comment actions Permalink

I see both of them are recognized well:

0
Comment actions Permalink

Do you have data source created? There should be 'languages' in target database, like this:

to get it works.

0
Comment actions Permalink

Thank you for the replies. I cannot see "languages" in my database folder anywhere. I have got a Postgresql datasource created, but there is nothing for languages. Only the schemas show up nothing else... (had to hide some schema names for security). How do I get IntelliJ Idea to show all the folders like in your screenshot?

 

0
Comment actions Permalink

I'm facing the exact same issue, schemas are directly listed under the database, nothing else.

But it works on another computer with the same Intellij version. I'm facing the issue on Macbook Pro with M1 chip, and Big Sur 11.2.

0
Comment actions Permalink

please right-click on database name -> refresh.

also enable 'show empty groups' here:

0
Comment actions Permalink

Thank you for your help. Empty groups are now displayed, but are empty of course. I already refreshed a dozen times.

I got 3 computers, one hosting DB through docker, two connecting to it with latest intellij version (same credentials, configuration, ...).
The one with m1 chip can only list schemas (and underlying objects). The other one with intel chip can list all objects.

Seems like a bug.

@Fishymoo what's your configuration?

0
Comment actions Permalink

My configruation is IntelliJ Idea Ultimate 2020.3
OS: Windows 10 Pro 64-bit, Intel i7-3770 CPU
PostgreSQL 13 installed locally.

No docker or anything else.

I enabled show empty groups which now shows the folders for foreign data wrappers etc, but of course they are empty.

0
Comment actions Permalink

The problem was solved automatically on my side... After a reboot of the computer, I had access to all objects

0

Please sign in to leave a comment.