Pycharm doesn't seem to recognize pytorch 1.7.1

I will try to be as concise as possible. And know that I am not very cognizant. So first off I am running windows 10. I have anaconda installed. I have installed the latest version of pytorch though the command line in anaconda prompt. That would be version 1.7.1 with the cuda toolkit v 10.2. Which I installed on the machine separately aswell, same version. I can actually get cuda to work through the anaconda powershell. However once I get into pycharm, the only pytorch package I can install is 1.6.0, which is cpu only.

What the hell?

5 comments
Comment actions Permalink

Nvm. Seems to be an anaconda problem after all.

0
Comment actions Permalink

what was the issue? seems I have the same "anaconda problem"

0
Comment actions Permalink

Roi Berger

Hi,

I'm not sure what the OP's issue was, but I can suggest to check your interpreter settings and make sure it points to python executable from the same conda environment as in your Anaconda shell. You can check it in python console:

import sys; print(sys.executable)
0
Comment actions Permalink

Hi Roi! I cannot remember the exact problem but I will check it out tonight and come back to you. It was something to do with package management in anaconda but I can’t quite remember the exact option. Ttyl

0
Comment actions Permalink

Ok had a look. So basically all it is is that the package you want to include in your environment doesn't show up in the package list(at least that was my problem) So all you have to do is to add the proper channel within anaconda. With pytorch the channel was pytorch. If you wanna check you can use conda list. Should show up with the channel. Hope this helps!

0

Please sign in to leave a comment.