Return to showing != for not equals?

Answered

Recently the IDE started displaying the not equals sign in Java code rather than the "!=".  Is there a way to disable that and let me see the text I actually typed rather than the changed text?

0
5 comments

Looks like you mean font ligatures. You can disable them in 

Settings (Preferences on macOS) | Editor | Font | Enable font ligatures or

Settings (Preferences on macOS) | Editor | Color Scheme | Color Scheme Font | Enable font ligatures.

See also https://stackoverflow.com/a/50627776/2000323 for some more information.

0

Thanks for the answer.  I checked both and the Enable font ligatures already were not checked.

0

I had to uncheck Settings (Preferences on macOS) | Editor | Reader mode | Font ligatures

Once I unchecked this, IDEA went back to displaying the "real characters"

1

Thank you for the information. The Reader Mode has been introduced recently for read-only files and files from External Libraries. This makes it easier to read comments because they look like formatted text. We plan to make the configuration of Reader Mode more obvious in scope of this request: https://youtrack.jetbrains.com/issue/IDEA-256658

-1

Thanks Mmontgom, that did the trick.  Note for others, the change doesn't show up until you restart the IDE.

0

Please sign in to leave a comment.