PHPStorm " because it already exists and is a file."

I'm trying to deploy development files from a Windows 10 (latest build) machine running PHPStorm (latest build) via a local LAN.

The server is running Ubuntu 20.04.

I am getting the following error:

[20/01/2021 14:03] Upload file 'D:\EBC Computers GIT Repository\AlltecUnsub\libraries\vendor\twbs\bootstrap\site\static\sw.js' to 'Z:\development.alltec.com\public_html\libraries\vendor\twbs\bootstrap\site\static\sw.js'
[20/01/2021 14:03] Failed to transfer file 'D:\EBC Computers GIT Repository\AlltecUnsub\libraries\vendor\twbs\bootstrap\site\static\sw.js'. Could not create folder "file:///Z:/development.alltec.com/public_html/libraries/vendor/twbs/bootstrap/site/static" because it already exists and is a file.

If I copy the files onto the samba share using Windows Explorer it works fine, and from then on I can just deploy the edited files - but every time I add files it fails to deploy!

Help please!

1 comment
Comment actions Permalink

Frankly, no idea. Do I get it right that you are using the "Local or mounted folder" deployment type?
If so, I can't find any similar reports on our tracker.
Please add #com.jetbrains.plugins.webDeployment to Help | Diagnostic Tools | Debug Log Settings, restart the IDE, reproduce the issue, and then submit the logs (Help | Collect Logs and Diagnostic Data) within a new bug report on our tracker: https://youtrack.jetbrains.com/newIssue?project=WI

Thank you!

0

Please sign in to leave a comment.