update to PyCharm 2020.3.3 fails with status code 403


I have been using PyCharm for ~6 months now and enjoy it.  Thank you PyCharm team!

Every time that I am prompted to update, I do so, and in the past it has worked every time with no issue, like it ought.

Unfortunately, the very latest update to 2020.3.3 fails.

An error dialog box appears with this text:

14:51 PyCharm and plugin updates
Failed to prepare an update:
Request failed with status code 403
Open download page.

Is the PyCharm team aware of this issue, and will it be fixed soon?

Anyone know why this happens?

Any cure besides going to the download page?

And if I have to manually download 2020.3.3, I would normally first uninstall my current version and then run the 2020.3.3 installer.  That will not cause me to lose any settings, will it?


There was a similar problem: https://youtrack.jetbrains.com/issue/WI-55712

But it has been fixed on JetBrains server side. 

So, I suppose the issue you reported is different. Please share the error from idea.log generated on the update attempt. 

As for uninstall/install method - yes, settings will be in place. To be sure all is safe, you can also use one of these three ways to backup all IDE settings: https://www.jetbrains.com/help/idea/sharing-your-ide-settings.html


Konstantin: thanks for getting back to me.

I tried to update again just now, that failed the same way as before, below is the final part of my idea.log file related to this update:

2021-02-03 09:05:15,297 [ 29057] INFO - hon.packaging.PyPIPackageCache - Loaded 287137 packages from C:\Users\haroldf\AppData\Local\JetBrains\PyCharmCE2020.3\python_packages\pypi-cache.json 
2021-02-03 09:05:31,038 [ 44798] INFO - eSettings.impl.UpdateInstaller - downloading https://download.jetbrains.com/python/PCA-203.6682.179-203.7148.72-patch-jbr11-win.jar
2021-02-03 09:05:32,316 [ 46076] WARN - eSettings.impl.UpdateInstaller - Request failed with status code 403
com.intellij.util.io.HttpRequests$HttpStatusException: Request failed with status code 403. Status=403, Url=https://download.jetbrains.com/python/PCA-203.6682.179-203.7148.72-patch-jbr11-win.jar
at com.intellij.util.io.HttpRequests.throwHttpStatusError(HttpRequests.java:671)
at com.intellij.util.io.HttpRequests.openConnection(HttpRequests.java:649)
at com.intellij.util.io.HttpRequests$RequestImpl.getConnection(HttpRequests.java:381)
at com.intellij.util.io.HttpRequests$RequestImpl.getInputStream(HttpRequests.java:390)
at com.intellij.util.io.HttpRequests$RequestImpl.saveToFile(HttpRequests.java:483)
at com.intellij.util.io.RequestBuilder.lambda$saveToFile$1(RequestBuilder.java:69)
at com.intellij.util.io.HttpRequests.doProcess(HttpRequests.java:541)
at com.intellij.util.io.HttpRequests.process(HttpRequests.java:523)
at com.intellij.util.io.HttpRequests$RequestBuilderImpl.connect(HttpRequests.java:355)
at com.intellij.util.io.RequestBuilder.saveToFile(RequestBuilder.java:69)
at com.intellij.openapi.updateSettings.impl.UpdateInstaller.downloadPatchChain(UpdateInstaller.kt:65)
at com.intellij.openapi.updateSettings.impl.UpdateInfoDialog$5.run(UpdateInfoDialog.java:230)
at com.intellij.openapi.progress.impl.CoreProgressManager$TaskRunnable.run(CoreProgressManager.java:962)
at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcessWithProgressAsync$5(CoreProgressManager.java:472)
at com.intellij.openapi.progress.impl.ProgressRunner.lambda$submit$3(ProgressRunner.java:235)
at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcess$2(CoreProgressManager.java:178)
at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(CoreProgressManager.java:658)
at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(CoreProgressManager.java:610)
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:65)
at com.intellij.openapi.progress.impl.CoreProgressManager.runProcess(CoreProgressManager.java:165)
at com.intellij.openapi.progress.impl.ProgressRunner.lambda$submit$4(ProgressRunner.java:235)
at java.base/java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1700)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1$1.run(Executors.java:668)
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1$1.run(Executors.java:665)
at java.base/java.security.AccessController.doPrivileged(Native Method)
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1.run(Executors.java:665)
at java.base/java.lang.Thread.run(Thread.java:834)
2021-02-03 09:06:22,292 [ 96052] INFO - j.ide.actions.RevealFileAction - Exit code 1

I hope that allows you to solve the problem.  It looks to me like another server side issue.  I will wait a day or so to see if you can fix it, and so test out your fix, before falling back on manual reinstallation.


I've encountered a similar issue on the Mac. The start of my error output is:

2021-02-04 09:40:04,135 [  52356]   INFO - eSettings.impl.UpdateInstaller - downloading https://download.jetbrains.com/python/PCA-203.6682.179-203.7148.72-patch-jbr11-mac.jar 
2021-02-04 09:40:05,723 [ 53944] WARN - eSettings.impl.UpdateInstaller - Request failed with status code 403
com.intellij.util.io.HttpRequests$HttpStatusException: Request failed with status code 403. Status=403, Url=https://download.jetbrains.com/python/PCA-203.6682.179-203.7148.72-patch-jbr11-mac.jar
at com.intellij.util.io.HttpRequests.throwHttpStatusError(HttpRequests.java:671)

I saw an issue on updating PyCharm with Anaconda from 2020.3.2 to 2020.3.3 that appears related, and the suggestion was to download the non-Anaconda edition: https://youtrack.jetbrains.com/issue/PY-46717

I am also using a PyCharm with Anaconda edition. Is the update issue because this edition is obsolete? Or a server-side issue? Thanks.


> Is the update issue because this edition is obsolete

You are right. We have stopped building PyCharm for Anaconda since 2020.3.3. Please use pure Community / Professional Edition. The differences are minimal so you should not notice any burden


Thanks for clarifying that!


Konstantin: I also use Anaconda3.  The very first time that I installed Anaconda3, I also clicked on its option to install PyCharm as well, so that first time I should have used your Anaconda3 build.

However, I subsequently uninstalled and then reinstalled Anaconda3 a few more times (because its auto update was failing...), and on all subsequent Anaconda3 installs, I never clicked on the option to install PyCharm.

Instead, I installed PyCharm Community separately, from a dedicated download of your installer.  Thereafter, I always accepted every PyCharm prompt to update itself, which always worked until now.

When I look at my  PyCharm's Help --> About it gives me:

PyCharm 2020.3.2 (Community Edition)
Build #PCA-203.6682.179, built on December 30, 2020
Runtime version: amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 1998M
Cores: 6
Non-Bundled Plugins: R4Intellij

So, is the issue that I am seeing totally different than David?



See the build info (PCA-203.6682.179). It is the version with Anaconda. Reinstalling IDE should help. 


Konstantin: thanks for confirming that.

I uninstalled my old PyCharm and installed a fresh download of Community 2020.3.3, which leaves me with:

PyCharm 2020.3.3 (Community Edition)
Build #PC-203.7148.72, built on January 27, 2021
Runtime version: amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 1998M
Cores: 6
Non-Bundled Plugins: R4Intellij

So, all now seems well.


When I uninstalled my old PyCharm, here is the dialog that came up:

Yes, that dialog confirms that my PyCharm build being uninstalled had an Anaconda plugin.

But also note how the text next to those 2 check boxes was clipped, leaving it barely readable.  That is a defect that you need to fix.

I, of course, did not check either box since I wanted to preserve all caches and settings.





Please sign in to leave a comment.