How to change default field type when importing csv


When importing csv data into an Oracle database text fields are automatically coaxed to CLOB fields (instead of VARCHAR2). There are multiple bug reports relating to this issue ( but I don't think this will be fixed anytime soon.


Is there a setting somewhere in the config files where we can change this ourselves?

1 comment
Comment actions Permalink

When importing the file you can click on the "DDL Preview" and change the data type.


Please sign in to leave a comment.