my pycharm can't be opened

when i opened my pycharm i got message "the application "PyCharm CE with Anaconda plugin" can't be opened

this is the pict

i already try installing a new version of pycharm but still got that message, the previous question is in russian so i cant understand. please help me fix this problem.

i'm using macbook air OS Mojave

8 comments
Comment actions Permalink

Hi, 

Could you please download the latest PyCharm from https://www.jetbrains.com/pycharm/download/ and check if you get the same issue?

0
Comment actions Permalink

yes. i still get the same error

i checked the python folder and run the pycharm program and found the error, this is the error i found

i already try change the value of Xms and Xmx in pycharm.vmoptions but still didnt work. what can i do next ?

0
Comment actions Permalink

Thank you, 

Could you please copy-paste the content of your pycharm.vmoptions file? The default values for Xms/Xmx flags should be something like: 

-Xms128m
-Xmx750m
0
Comment actions Permalink

thanks for the reply Andrey Resler

pycharm.vmoptions

-Xms128m
-Xmx512m
-XX:MaxPermSize=300m
-XX:ReservedCodeCacheSize=240m
-XX:+UseConcMarkSweepGC
-XX:SoftRefLRUPolicyMSPerMB=50
-ea
-XX:CICompilerCount=2
-Dsun.io.useCanonPrefixCache=false
-Djdk.http.auth.tunneling.disabledSchemes=""
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow
-Djdk.attach.allowAttachSelf=true
-Dkotlinx.coroutines.debug=off
-Djdk.module.illegalAccess.silent=true
-XX:+UseCompressedOops
-Dfile.encoding=UTF-8

-XX:ErrorFile=$USER_HOME/java_error_in_pycharm_%p.log-XX:HeapDumpPath=$USER_HOME/java_error_in_pycharm.hprof

i already trying change the Xmx up to 1G but still cant open my pycharm

0
Comment actions Permalink

Do you still get "initial heap size is larger than maximum" error? 

0
Comment actions Permalink

I suspect a wrong vmoptions file maybe picked up somewhere from your system. 

I would suggest a clean reinstall from https://www.jetbrains.com/pycharm/download/ while also deleting directories belonging to 2020.3 and previous versions:

[PyCharm 2020 directories](https://www.jetbrains.com/help/pycharm/directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html)
[PyCharm 2019 directories](https://www.jetbrains.com/help/pycharm/2019.3/directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html)

This should make sure you start with the correct vmoptions file.

0
Comment actions Permalink

Andrey Resler
i found the source of my problem, it's still the xms and xmx value, i checked the file in wrong place, i should replace the value on pycharm.vmoptions on JetBrains folder not pycharm folder. thank you so much for your concern, your help is mean a lot for me

0

Please sign in to leave a comment.