How to config custom plugin repository with 'idea.plugins.host'?

Answered

Hi, 

I wrote my own updatePlugins.xml file, and configured it though Plugins -> Manage plugin Repositories -> + -> "http://xx-server:8000/updatePlugins.xml". Then I can see the custom plugins in Marketplace, it succeed.

 

But on page https://www.jetbrains.com/help/idea/managing-plugins.html#required-plugins, it says that I can alternatively use idea.plugins.host to replace the JetBrains Plugin Repository, so I add one line through Help -> Edit custom properties. But failed with the following four configurations:

  • idea.plugins.host="http://xx-server:8000/updatePlugins.xml"
  • idea.plugins.host="http://xx-server:8000/"
  • idea.plugins.host=http://xx-server:8000/updatePlugins.xml
  • idea.plugins.host=http://xx-server:8000/

 

All of them have the same error:

Is there any wrong with my config?  I am using IDEA 2020.3 community.

10 comments
Comment actions Permalink

Hello,

Could you please share your idea.log ("Help | Show Log in...") after restarting IDE?

0
Comment actions Permalink

Sorry, there is a restriction to submit the whole idea.log file in our company, if you can give some keyword, I could paste the relate results.

0
Comment actions Permalink

Leon,

I need just startup lines describing common IDE configuratiuon to check that property was enabled.

0
Comment actions Permalink

That property is enabled, I find this log:

It tried to access xxx/api/search/plugins?xxxxxx, and I don't have it.

0
Comment actions Permalink

Leon,

Did you get this message after opening "Plugins" settings page? Could you please enter address manually in "Manage plugin Repositories" and check logs again - what URL will be used?

0
Comment actions Permalink

There is no other message in IDEA UI,  but ther is an Error in terminal :

 

Though "Manage plugin Repositories", the result is :

It works ok and the url address changed to plugins.jetbrains.com in the idea.log:

0
Comment actions Permalink

I think it's a bug of the example on the help doc. It should be:

idea.plugin.hosts
Not:
idea.plugins.host
 
0
Comment actions Permalink

Leon,

Does it work with "idea.plugin.hosts"?

0
Comment actions Permalink

 "idea.plugin.hosts" works ok.

0
Comment actions Permalink

Leon,

Thanks! I'll ask to add more information about those options. "idea.plugins.host" also might be used. In this case you specify a URL to an application that should be ready to requests that IDEA sends to plugins.jetbrains.com: for example, "/plugins/list?build=<buildnumber>"

0

Please sign in to leave a comment.