How to auto align (indent) when pressing Enter after a comma?

After I press Enter, the caret is as follow

, while I expect it is

To achieve the latter, I have to press Tab again. Is there any setting to make the caret align as I expect?

5 comments
Comment actions Permalink

do you have a 'tab' or 2 spaces between 'select' and column name?

0
Comment actions Permalink

After enter SELECT (from code autocompletion), I get

Then I press Tab (to get more space) and then type in "s.idcompany,". I also want to ask why I got only 1 space when pressing Tab.

0
Comment actions Permalink

Please check what is set here - File | Settings | Editor | Code Style | SQL | <you dialect> -> Tabs and indents.

0
Comment actions Permalink

Here they are

and

0
Comment actions Permalink

If I do not press Tab after "SELECT", i.e. there is only 1 space between "SELECT" and "s.idcompany". Then everything works well.

0

Please sign in to leave a comment.