Switching among windows partly broken (macOS)



After I upgraded to the latest GoLand version 2020.3.2 (my previous version was quite old), I have the following issue:

When I have multiple GoLand windows for different projects open at the same time, the switching among windows works only between two of the projects. To get the third one into the foreground I have to manually shift windows around and find it. I don't have this problem for any other application.

My computer is MacBookPro with macOS Big Sur 11.1.

Is this a known problem? Is there a workaround/fix for it?

Thank you,




Hi Selda,

Please, provide a little bit more details as I cannot reproduce the issue yet.

Are you open projects on fullscreen mode? Do I understand correctly that you use Next/Previous Project Window shortcuts?

By the way, give a try to Big Sur tabs, please see: https://www.youtube.com/watch?v=oRdpG80sRIs

Best regards,
Daniil Maslov


Hi Daniil,

Thanks a lot for your fast response. 

No, I don't have the projects on fullscreen mode. 

Yes, right, I mean Next/Previous Project Window shortcuts. I remembered now that I had made a custom configuration for it (alt-tab). Maybe it is related to that.




Thanks for the update.

Please see the comment about this action.

You need to configure the action inside the IDE: Preferences | Keymap | Activate Next Window or Activate Previous Window.

I hope it helps.


Thank you for your help.

Yes, right. This is the same problem described in that thread. I now try to configure the shortcuts in Preferences | Keymap | Activate Next Window or Activate Previous Window. However entering `tab` or `alt` for keyboard shortcut does not work. How can I configure those keys?


I can select Option+Tab on Keyboard Shortcut assign window.

So, what keyboard layout are you using (macOS Preferences | Keyboard | Input Sources)? Does it help if you reassign Move focus to next window (macOS shortcut) to another and then try to configure it inside the IDE?


I am using the layout labelled as "ABC".

The trick you suggested worked to enter the shortcut in GoLand. Then I changed back the one in macOS settings. So now in both macOS and GoLand I have the correct shortcut configured. 

However still looping through 3 windows does not work. (I also restarted GoLand.) It still switches between 2 of them. :|

Thank you for your support.


Thanks for the update.

You need to configure Activate Next Window or Activate Previous Window action to the different shortcuts from your system one since macOS will interrupt your IDE action on any case and you get back to the issue that you're described originally.


So do I understand correct, that, if I have a custom shortcut, it is not possible anymore to use the same shortcut which I use normally on macOS also in GoLand? 

Thank you.


That's correct, because macOS interrupt your IDE action.


I am quite sure that this was possible before I upgraded GoLand. I hope it will be fixed again in some future version.

Thanks a lot for your support Daniil


I strongly encourage setting the default shortcuts for

Activate Next Window

Activate Previous Window.

to the default mac shortcuts, while regarding the OS's current Keyboad Layout

On a German Layout this would be: 




-> please put this in your pipeline


Johannes1 Hoerteis, thanks for your feedback. Feel free to follow IDEA-165950.


Please sign in to leave a comment.