Fresh install of goland fails to recognize imports that it imported?


Windows 10 fully updated

1) install go via official installer. Use all default options

2) install goland via recommend method by jetbrains

3) make new project.

4) make new go file

5) copy and paste example code into file which relies on "github...." Imports

6) click the pop up which asks if you would like to "go get....."

7) goland still can't find the import despite it being downloaded.

8) cry because it would make too much sense for a default install with default options to be able to find imports that the IDE itself imported......

9) thank God you didn't buy this yet and it is only a trial

10) start downloading competitors products to see if they are sensible

11) make support post just in case there is reasonable explanation for this otherwise unacceptable behavior

12) edit post to add two returns after each paragraph because a wysiwyg editor is apparently out of fashion

Official comment

Thanks for the report and your reply.

We already fix the issue, for more details please see GO-10639.


Probably, it's a mistake on our side. Could you please provide a code snippet and on what line you execute go get ... action?

It would also be useful if you share IDE logs (Help | Collect Logs and Diagnostic Data) and upload them here. Please, provide its name after that.

Thanks in advance.


Well, I tried changing many things. The change that finally made it work was calling the following commands from the command line from the project folder (awesomeProject)

go mod init awesomeProject

go mod tidy

I have no idea if any other settings that I changed mattered. But that was the final piece.

Why does goland not perform or suggest to perform these actions automatically?

Clearly, goland's default behavior "go get" suggestion gets the files in a way that require modules to be initiated to work. Why is this just not part of the flow? Why make it so obtuse? Why am I going to the command line to fix this?

What am I doing wrong? Surely, this is not the intended work flow???



I installed gin using "go get -u" on Mac command prompt at my GOPATH. In my project go files, I see import errors. Any idea why Goland is not recognizing 'gin'?



I see issue is fixed. What are the steps to resolve this issue for existing installation of Goland?


Hi Ios Mxe,

The fix is available on the latest EAP version. Please, download it from here.

If you can't download the EAP version, as a workaround, you can create a go.mod file or a project based on Go Modules instead and the problem will be solved.


Thanks Daniil!

It worked with EAP version!


Please sign in to leave a comment.