WSL2 - specified path cannot be found

I try to run the project with WSL2 but there is a problem with the path

The CLI interpreter is configured:

The WSL instance works:

Note: I am working with WSL2 and the same project in VSCode without any problems

Where is the problem?

(PS. i use latest PHP Storm)

1
15 comments

Hm, that's strange, looks similar to https://youtrack.jetbrains.com/issue/IDEA-252213, but we need more info about your setup.

Is it a simple distrib installed from a MS Store?

0

Complete information about my setup:

  • Windows 10 20H2 (OS Build 19042.867)
  • Ubuntu-20.04 (Default) (Official distrib from MS Store)

PHPStorm version info:

PhpStorm 2020.3.3
Build #PS-203.7717.64, built on March 16, 2021
Licensed to PhpStorm Evaluator
Expiration date: April 22, 2021
Runtime version: 11.0.10+8-b1145.96 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 1961M
Cores: 8
Registry: run.processes.with.pty=TRUE

Screen from MS Store:

Some screens from shell:

 

0

Thanks, everything looks right. Could you please try to open the File > Open window again to reproduce the problem, then collect IDE logs (run Help > Collect Logs and Diagnostic Data) & upload them to our portal? You can use https://uploads.jetbrains.com/ for this. Please let me know the upload ID after that.

0

Upload ID: 2021_03_24_17PL2yjw98tntkrR

0

Thanks, there are no WSL-related errors. Could you please check if it's any better in EAP build?

0

in the EAP compilation it sees WSL, but it's "inactive". GIFVideo example below:

0

Thanks! Could you please upload the logs collected in 2021.1 EAP build?

0

Upload ID: 2021_03_24_4YhFrpvwzkntW6S6

0

Thanks, I can see there's "java.nio.file.FileSystemException: \\wsl$\Ubuntu-20.04\..... Unable to determine if root directory exists" error message. We don't have any similar reports, this one should be looked closely by a corresponding team. It would be great if you could submit this to our tracker at https://youtrack.jetbrains.com/newIssue attaching the logs from 2021.1 installation. That way developers would be able to look into this further.

0

I am having the same issue. Are there any news? Which ticket is it?

 

0

Patrick, there are no known issues with listing the WSL share in 2021.2. Please check if wsl --shutdown && wsl solves the issue for you.
If it does not, please submit your logs directory within a support ticket (Help | Contact Support).

0

The same issue here. Directory listing is unavailable for PHPStorm

0

Maybe someone else will find it useful. Check your environment variables in Windows, PATH should have the following entries "C:\Windows\System32\" and "C:\Windows\System32\WindowsPowerShell\v1.0\". I spent 4 hours trying to figure out why my WSL directory fell off, it turned out that without these entries in the environment variables, storm does not know where WSL and Powershell are located

3

You're a genius, man! Thanks a lot!

1

Please sign in to leave a comment.