Can't open the Webstorm after installation on Big Sur. Version Webstorm 2021.1.

I was running version 20.3. Suddenly it stopped opening. I downloaded and reinstalled Webstorm for version 2021.1.

And even after these manipulations, the application also does not start.

Mac OS Big Sur version 11.2.3

1
11 comments

It will be included in 2021.1.2 update

1

please share your idea.log (~/Library/Logs/JetBrains/WebStorm2021.1)

Also, what is a result of starting the IDE from terminal (browse to the /Applications/Webstorm.app/Contents/MacOS/webstorm executable in Finder, in the context menu choose Open With, Terminal)? What is written to console?

0

I have the same problem with Big Sur. Both Webstorm and Rubymine just beachball after the logo appears. I had to downgrade back to 2020.3 to get my IDE to work.

0

Looks like https://youtrack.jetbrains.com/issue/IDEA-266474.

You can add -Dnosplash=true in Help | Edit Custom VM Options as a workaround or nosplash to the command line.

Sorry for the inconvenience.

0

Thanks, Elena. That works for me. Looks like the issue was fixed based on the conversations in the other thread. Any idea when it will be released to the general public?

0

I have the 2021.3 version and it's still happening. Was this issue fixed?

0

it was, you must be facing a different problem. Please file a new ticket to youtrack

0

2021.3.1 and having the same issue. My solution is reinstalling the app, but this has been the 5th time I have had to do that. 

Can someone share the command for Mac to start it up from command line without the `nosplash` option?

Thanks

0

Elena Pogorelova my problem is not with IDAE, problem I am having is with Webstorm (directory structures are different) - and even tho I go to

/Applications/JetBrains Toolbox/WebStorm Release.app/Contents/MacOS

the `jetbrains-toolbox-launcher` doesn't work 

Also, I've followed the steps you have mentioned here https://intellij-support.jetbrains.com/hc/en-us/community/posts/360010616359/comments/360003174259 - and while try to open it, it hangs there and no progress, and never opens.

Any more tips on how to solve this? Currently I'm working with 2021.1 version, and so far haven't had that problem. (although I've limited the times I've restarted the application/computer) 

0

I had the same issue. I was able to uninstall Webstorm using Jetbrain Toolbox. Then re-install it (using Jetbrain Toolbox).

0

Please sign in to leave a comment.