Run Git hooks checkbox

Previously if I've removed this checkbox it was removed for the next commits as well. PHPStorm does not support remote Node.js interpreter. We're using Docker for dev env, so I run all commands in the docker container. We're using husky (I'm not because of the remote node interpreter). And now I'm not able to rebase. Looks like Storm trying to use husky locally and fails, so interactive rebase fails as well!

0
5 comments

Oh, the same problem with merge ((

PhpStorm 2021.1.1
Build #PS-211.7036.8, built on April 15, 2021
Runtime version: 11.0.10+9-b1341.35 amd64
VM: Dynamic Code Evolution 64-Bit Server VM by JetBrains s.r.o.
Linux 5.4.0-72-generic
GC: G1 Young Generation, G1 Old Generation
Memory: 1994M
Cores: 8
Registry: run.processes.with.pty=TRUE

Current Desktop: X-Cinnamon

0

Please let me get this straight - the issue is that the checkbox state is not preserved between Commit window invocations, right?

0

Eugene Morozov yes, I need to disable the pre-commit hook

0

According to this issue, it's been like that for a long time now. Please vote. For now, you'll have to keep in mind to disable it each time, unfortunately.

0

Eugene Morozov probably I had not conflicts previously with node versions

0

Please sign in to leave a comment.