Intellisense for terraform files not working for some files

Answered

Hi all,

I have the following problem in Intellij:

When I create a file _secrets.tf or _providers.tf in IntelliJ is not recognising the files as terraform files.

When I rename the files to _secret.tf or _provider.tf (so singular) it is working.

Does anyone knows what the problem is here?

Thanks!

Manuel 

4 comments
Comment actions Permalink

Hello,

Unfortunately, the problem is not reproduced for my work environment.

Can you please attach a screenshot from Settings/Preferences | Editor | File Types | Terraform config files section, your _secrets.tf file, and collect diagnostic data? (Help | Collect Logs and Diagnostic Data)

Try using the 2021.1.1 IDE version from https://www.jetbrains.com/idea/download .

The files can be uploaded at https://uploads.jetbrains.com . (do not forget to specify the UploadID)

0
Comment actions Permalink

Hi Egor,

thanks for you quick answer!

I gonna upload it.

My colleague hasn't that problem and we compared already the configuration. 

But now it works when I remove the _ before the files. It's really strange :)

 

Cheers

Manuel

0
Comment actions Permalink

Hey Egor,

I have uploaded the screenshot (2021_05_06_JW3YsDHuHh23nppp). 

Let me know if you needs some more information.

 

Cheers

Manuel

0
Comment actions Permalink

Thank you for sharing a screenshot. Please try using the 2021.1.1 IDE version from https://www.jetbrains.com/idea/download and temporarily disable all third-party plugins except "HashiCorp Terraform / HCL language support".

If the problem remains please collect the IDE logs. (Help | Collect Logs and Diagnostic Data)

0

Please sign in to leave a comment.