Edit Source Does Not Include Schema Qualifiers

Answered

When I use edit source (ctrl + B) or jump to source (f4) the source generated does not include fully qualified objects on the alter/grant commands. If I generate DDL (ctrl + alt + shift + B) it correctly includes the qualification.

Example:

I edit source for reporting.vw_dim_date and at the bottom it generates as "grant select on vw_dim_date to ro_user"

If I generate DDL it shows as "grant select on reporting.vw_dim_date to ro_user"

Is there a setting I'm missing which can include qualification? I really like the efficiency of being able to pull up a window to edit the source code so easily but with views/procedures that have a lot of alter/grant commands it defeats that efficiency by requiring me to add qualification.

1 comment
Avatar
Yuriy Vinogradov
Comment actions Permalink

this is expected behavior, cause when you open source in editor with CTRL+B - it has schema-level context, this is why no objects are qualified here.

0

Please sign in to leave a comment.